Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I haven't updated my server (10.10) for quite a while.

I updated package information with sudo apt-get update and then ran sudo apt-get upgrade as usual, which resulted in:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

What could possibly be wrong?

share|improve this question

4 Answers 4

up vote 1 down vote accepted

Ubuntu 10.10 (Maverick Meerkat) end-of-life reached on April 10, 2012

as here https://wiki.ubuntu.com/Releases

see the announcement here https://lists.ubuntu.com/archives/ubuntu-announce/2012-April/000158.html

Even if you are sure , system is not upto date as far as last updates is concerned , cross-check the packages Version here

Last update was made on 5th April as here

share|improve this answer
    
Seems like I updated somewhere in may and these where the last updates. –  Dziamid Jul 19 '12 at 9:19

Ubuntu 10.10 has reached its EOL in April 10, 2012, there are no more updates for it. If you want to sue more recent software and up to date packages you need to upgrade.

share|improve this answer

This is likely because support for most Ubuntu releases lasts 18 months. (Except for LTS releases, e.g. 10.04 and 12.04, where support is for three/five years.)

Support for Ubuntu 10.10, which was released in October 2010, ended on the 10th April 2012. This means that the update servers for 10.10 are no longer online.

share|improve this answer
    
I wouldn't say the update servers are no longer online, just no longer maintained. They're still online at old-releases.ubuntu.com/releases. I frequently end up adding those to the sources.list when I need to add packages to an old system to assist in migrating its content to another system running a new version. –  Steven Kath Jun 2 '13 at 18:10

You could enable the updates for 10.04, that's your only option at the moment. You can achieve that by editing your sources.list as explained below:

  • Pack that sources.list up first (important!): gksudo gedit /etc/apt/sources.list

  • Then use replace to replace the word 'maverick' for the word 'lucid'

  • Save the file

  • Run sudo apt-get update again

You might get an error about some link extras.ubuntu.com, hash them out from the sources.list file and run again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.