Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
There's an issue with an Alpha/Beta Release of Ubuntu, what should I do?

I have a new Alienware M17x which I have installed 64-bit Ubuntu 12.10 (dual boot). I have tried various ways to install the Nvidia drivers for the GeForce GTX 680M (which they claim they are compatible with):

  • from Ubuntu Software Centre (though Additional Drivers fails to detect the card.)
  • using sudo apt-get install nvidia-current
  • downloading the drivers from nvidia and manually installing them (ctrl + alt + F6, sudo service lightdm stop, sudo ./NVIDIA*, sudo reboot)

(each with a clean install of Ubuntu) but in all cases, when I reboot after installing nvidia-setings claims that I am not using the driver and should sudo nvidia-xconfig from the terminal, which I do but this has no effect and I am stuck in crappy resolution until I rm /etc/X11/xorg.conf and reboot.

The xorg.conf that nvidia-xconfig generates is:

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
share|improve this question

marked as duplicate by fossfreedom Sep 12 '12 at 13:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
I have the same problem with 640M LE –  nobeh Jul 21 '12 at 13:03
add comment

1 Answer 1

The way I solved this problem, was to install Bumblebee to enable optimus.

For some reason the default video card seen in Ubuntu is the integrated Intel card and installing the Nvidia drivers without bumblebee causes a mess. The installation is pretty painless. To run your software with the Nvidia chip, you need to open terminal (Ctrl+alt+T) then type optirun in front of whatever you want to run.

An added benefit is you will get better battery life as the Nvidia graphic card will be turned off when not in use.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.