Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing Ubuntu 12.04 (clean install) I fetch a bunch of program via synaptic (installed specially), all programs worked except Gimp 2.8. So I tried purging Gimp, install again (no luck). Checked broken packages and reinstalled them. When using the Software center I get this MSG:

Failed to fetch http://is.archive.ubuntu.com/ubuntu/pool/main/o/openexr/libopenexr6_1.6.1-4.1_amd64.deb Size mismatch

Tried also this:

sudo apt-get purge gimp*
sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update
sudo apt-get install gimp

And get this MSG:

Failed to fetch http://is.archive.ubuntu.com/ubuntu/pool/main/o/openexr/libopenexr6_1.6.1-4.1_amd64.deb  Size mismatch
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

I am wondering if the Icelandic Archive has an outdated version or something?

would really like to install Gimp 2.8 but Gimp 2.6 is OK to.

I am also wondering if I am doing something wrong?

share|improve this question
    
Have you changed the mirror? and is still giving you that error? –  Uri Herrera Jul 18 '12 at 22:21
    
It worked. just did it this evening. I found there is another mirror or archive in Iceland (didn't try it) the norway one worked. I now have Gimp 2.8. Still feels slower then 2.6 but that is a problem I also have on my windblows 7 computer. Thanks again for your help and follow up :) Were could I go to learn more about the (for exemple) the commands you sent me and maybe general terminal commands?. Thanks again, regards from Iceland. –  Birgir Freyr Jul 19 '12 at 23:31
add comment

2 Answers 2

up vote 0 down vote accepted

The Iceland mirror (Siminn hf) is one week out of date.

Please try one of these up-to-date mirrors that should be close to you, network-wise:

Norway: https://launchpad.net/ubuntu/+mirror/ftp.blix.eu-archive Netherlands: https://launchpad.net/ubuntu/+mirror/nl3.archive.ubuntu.com-archive UK: https://launchpad.net/ubuntu/+mirror/ftp.ticklers.org-archive

share|improve this answer
    
Thanks for the quick reply. I am a bit of a newbie in regards to terminal action and using synaptic so forgive me for asking how to do I activate the norway mirror? Why is the the Icelandic mirror one week out of date? Is there anything I can do about it? –  Birgir Freyr Jul 18 '12 at 23:08
    
No need for the terminal. Please press alt-f2 and type gksudo software-properties-gtk and scroll down by country and manually select the mirror. Then press update, I think, or type sudo apt-get update in the terminal. Unfortunately, nothing you can do about the .is mirror -- not unless you know someone high up in Siminn management ;). A lot of mirrors are like that, it's just your luck that this is the only local one for you. –  izx Jul 18 '12 at 23:22
    
YES. it worked. Were can I learn more about the commands you sent me? would like to become more confident in what I am doing in Ubuntu and learn more. But thanks for the help. –  Birgir Freyr Jul 19 '12 at 23:26
    
@BirgirFreyr: in that case, please accept the answer (tick/check mark on left), so that the question is marked as closed and future readers know the solution worked. :) I will add another comment shortly with some resources that may be helpful. –  izx Jul 19 '12 at 23:32
    
thanks again. :) –  Birgir Freyr Jul 20 '12 at 9:26
add comment

Clarification: The mirror is provided by Listaháskólinn ( LHI.is ), and yes, it is out of date and has been for a long time now.

The solution is to redirect archive searches to another mirror. I have used se.archive instead, since it's net-wise pretty close (on Nordunet/Sunet).

The solution is to do:

sudo sed -i.bak 's/is.archive/se.archive/g' /etc/apt/sources.list

Which switches your source of packages to Sweden.

Please note: All traffic destined for NORDUNET should be handled as domestic traffic (isl: ekkert útlandaniðurhal) since the traffic is routed through the RIX which is a domestic end-point for the telcos.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.