Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Tried installing the Tata Photon+ bundled software which worked in 11.04, but does'nt install now in 12.04. Some error showing missing kernel modules(see below) anyone has a patch??

=============
Installing version: 21.005.11.03.628

The software is exist. Do you want overwrite it? ([Y]/N):Y

Local path is: /usr/local/Tata_Photon+/Tata_Photon+

Installing Tata Photon+.../usr/local/Tata_Photon+/Tata_Photon+/driver/ndis_driver
Usage: modinfo [-0][-F field][-k kernelversion][-b basedir]  module...
 Prints out the information about one or more module(s).
 If a fieldname is given, just print out that field (or nothing if not found).
 Otherwise, print all information out in a readable form
 If -0 is given, separate with nul, not newline.
 If -b is given, use an image of the module tree.
ERROR: Removing 'cdc_ether': No such file or directory
ERROR: Removing 'usbnet': No such file or directory
ERROR: Removing 'hw_cdc_driver': No such file or directory
make -C src/ clean
make[1]: Entering directory `/usr/local/Tata_Photon+/Tata_Photon+/driver/ndis_driver/ndis_src/src'
rm -rf *.o *.ko *~ core* .dep* .*.d .*.cmd *.mod.c *.a *.s .*.flags .tmp_versions Module.symvers Modules.symvers *.order
/usr/local/Tata_Photon+/Tata_Photon+/driver/ndis_driver/ndis_src/src/add_header.sh  "clean" "/lib/modules/3.2.0-24-generic/build/include/linux/usb"
rmmod -f hw_cdc_driver
ERROR: Removing 'hw_cdc_driver': No such file or directory
make[1]: *** [clean] Error 1
make[1]: Leaving directory `/usr/local/Tata_Photon+/Tata_Photon+/driver/ndis_driver/ndis_src/src'
make: *** [clean] Error 2
make -C src/ modules
make[1]: Entering directory `/usr/local/Tata_Photon+/Tata_Photon+/driver/ndis_driver/ndis_src/src'
#/usr/local/Tata_Photon+/Tata_Photon+/driver/ndis_driver/ndis_src/src/add_header.sh  "modules" "/lib/modules/3.2.0-24-generic/build/include/linux/usb"
make -C /lib/modules/3.2.0-24-generic/build SUBDIRS=/usr/local/Tata_Photon+/Tata_Photon+/driver/ndis_driver/ndis_src/src modules
make[2]: Entering directory `/usr/src/linux-headers-3.2.0-24-generic'
  CC [M]  /usr/local/Tata_Photon+/Tata_Photon+/driver/ndis_driver/ndis_src/src/hw_cdc_driver.o
/usr/local/Tata_Photon+/Tata_Photon+/driver/ndis_driver/ndis_src/src/hw_cdc_driver.c:155:27: fatal error: linux/usb/ncm.h: No such file or directory
compilation terminated.
make[3]: *** [/usr/local/Tata_Photon+/Tata_Photon+/driver/ndis_driver/ndis_src/src/hw_cdc_driver.o] Error 1
make[2]: *** [_module_/usr/local/Tata_Photon+/Tata_Photon+/driver/ndis_driver/ndis_src/src] Error 2
make[2]: Leaving directory `/usr/src/linux-headers-3.2.0-24-generic'
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/usr/local/Tata_Photon+/Tata_Photon+/driver/ndis_driver/ndis_src/src'
make: *** [modules] Error 2
make -C src/ install
make[1]: Entering directory `/usr/local/Tata_Photon+/Tata_Photon+/driver/ndis_driver/ndis_src/src'
#install -m 744 -c hw_cdc_driver.o /lib/modules/3.2.0-24-generic/kernel/drivers/usb/net
#depmod -a
#modprobe hw_cdc_driver
/usr/local/Tata_Photon+/Tata_Photon+/driver/ndis_driver/ndis_src/src/add_header.sh  "install"
modprobe hw_cdc_driver
FATAL: Module hw_cdc_driver not found.
make[1]: *** [install] Error 1
make[1]: Leaving directory `/usr/local/Tata_Photon+/Tata_Photon+/driver/ndis_driver/ndis_src/src'
make: *** [install] Error 2

Install NDIS driver failed.
The compiling environment is not all ready.
Please check gcc, make and kernel buid(/lib/modules/3.2.0-24-generic/build) to be all installed?
Now please enter any key to finish other installations.

NDIS is disabled, and only Modem can be used.
AUTORUNPATH=/home/eumesbs/.config/autostart
ADDRUNLEVEL=/etc/rc3.d
`/etc/rc3.d/S99runhwactivator' -> `/etc/init.d/runhwactivator'
`/etc/rc3.d/K10runhwactivator' -> `/etc/init.d/runhwactivator'
ADDRUNLEVEL=/etc/rc4.d
`/etc/rc4.d/S99runhwactivator' -> `/etc/init.d/runhwactivator'
`/etc/rc4.d/K10runhwactivator' -> `/etc/init.d/runhwactivator'
ADDRUNLEVEL=/etc/rc2.d
`/etc/rc2.d/S99runhwactivator' -> `/etc/init.d/runhwactivator'
`/etc/rc2.d/K10runhwactivator' -> `/etc/init.d/runhwactivator'
ADDRUNLEVEL=/etc/rc5.d
`/etc/rc5.d/S99runhwactivator' -> `/etc/init.d/runhwactivator'
`/etc/rc5.d/K10runhwactivator' -> `/etc/init.d/runhwactivator'
                                                                                                                                                                                 [ done ] 

Finished, press any key to exit



=============
share|improve this question
    
Please check out this site and see if it helps. –  SirCharlo Jul 18 '12 at 18:07
    
And here's a Ubuntu Forums link where people using Tata Photon have posted in the past. –  user25656 Jul 19 '12 at 2:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.