Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since the C drive on my dell dimension 4600 has little space left on it, I decided to install Ubuntu 12.04 LTS on a USB, load Ubuntu to my Iomega 250 GB external hard drive. I used 2gb for mount point / in ex4, 4gb for swap space and the rest for /home in ex4 also. I have set the bootloader to the hard drive, and the installation finished fine.

After restarting then booting from it, and reinstalling Ubuntu on it multiple times, the same error message appears. However I can get to the pink screen and when I choose the first option I get a pink screen which stays for 30mins, or this error message. Then after turning the computer off and on again, I go to the second option on the first pink screen which show a lot of white upon black text. Then the error message shows.

Irritatingly, I can't type "help" to get the commands as my computer keyboard is disabled at this point.

enter image description here
As I'm new I'm sorry for any missed details.

Here are some specs of my (desktop) computer:

  • 120GB internal hard drive
  • 4 GB RAM
  • Intel Pentium 4 (3 GHz)
  • 128MB GeForce FX 5200 (NVidia)
  • Windows XP SP3

The USB had Ubuntu 12.04 loaded onto it from Universal USB installer.

Could someone please tell me how to get Ubuntu working and why this happens. Thank you.

share|improve this question
    
See these similar posts boot drops to busy box shell and boot fails, drops to initramfs prompt –  Peachy Jul 19 '12 at 6:30

2 Answers 2

So first things first, booting off of an external USB hard drive will be extremely slow. I've done it before, and its really hard to deal with. Read and write times will be significantly slower, especially since you probably are not using USB 3.0

What First suggestion: give THIS page a read. Set 90 as the time out in the kernel parameter. Try that and let us know what happens.

Also, you can try using the program "EasyBCD" in Windows to edit your master boot record to try to fix the boot sequence. I'd give the timeout change a try first, and if that doesnt work we can look at the EasyBCD.

share|improve this answer
    
I've changed to rootdelay to 90, but the same message came up again, just taking longer to appear. I have installed EasyBCD, so please can you help me in how to use it. –  Oscar Brennan Jul 19 '12 at 16:33
1  
I don't know if this might help. –  Oscar Brennan Jul 19 '12 at 16:49
    
1. Here is a solution regarding the alert you got. Read that first. 2. Here is a video that shows a walkthrough for using EasyBCD. 3. Here is a detailed guide to adding ubuntu to the windows bootloader and setting the two up using EasyBCD. And it has nice screenshots with explanations. 4. Here is yet another guide for using EasyBCD. –  sbzenth Jul 19 '12 at 20:28
    
So what you are doing with EasyBCD is adding Ubuntu to the Windows Bootloader. The GRUB2 bootloader is going to be installed on your external hard drive, so what you want to do is point the Windows Bootloader to boot GRUB2, which should point to the partition that is your external. Then, the windows bootloader will pass you off to GRUB, from where you should be able to select ubuntu. It might help to check out the GRUB2 tutorial reference to get an idea of how GRUB works. –  sbzenth Jul 19 '12 at 20:36
1  
I have 2 problems with EasyBCD: It does not allow for ubuntu with GRUB2 to be on an external drive, and you can only use the 'Install BCD' function on Windows 7 and Vista, not XP. –  Oscar Brennan Jul 21 '12 at 13:03

You are doing a USB to USB install, so check out bug:
https://bugs.launchpad.net/ubuntu/+source/grub-installer/+bug/384633
The initial grub.cfg generated by install is wrong after the install media is removed, as all the disks get renamed one letter higher, and your new target system is left as a non-existent sdc instead of sdb. At the grub menu screen, look at the instructions at the bottom, and type e to edit, then fix the device on the search line for root= and on the linux ... line. At the first successful boot, run

  sudo update-grub 

to fix the config file.
Feel free to add yourself to the "does this affect you" list on the bug, and maybe it will be fixed someday.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.