Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently installed Ubuntu 12.04. However I'm having some problems with the graphic drivers.

My graphic card is GeForce 7150m / nForce 630. I've installed a lot of updates, however I can only run Ubuntu in 2D and most applications are very slow(e.g. google earth, or pressing alt+tab).

Does anyone has any idea how I can solve this problem? I'd be very grateful. Thanks. Daniel.

share|improve this question
    
Do you only have one graphic card? Or have more? You say you installed updates, but what updates? You need to install your graphic card drivers, so you can get acess to the 3d capability of your card. –  LnxSlck Jul 18 '12 at 14:49
    
I only have one graphic card. I installed updates trough the command sudo apt-get update sudo apt-get install nvidia It hasn't worked tho... –  Daniel Jaló Jul 18 '12 at 15:43

1 Answer 1

up vote 0 down vote accepted

Instalation through PPAm just purge your previus install and reinstall again

Run:

sudo add-apt-repository ppa:nvidia-vdpau/ppa
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys CEC06767
sudo apt-get update
sudo apt-get install nvidia

If that doesn't work you can try the propietary drivers from Nvidia, you can try this:

  1. Go to http://nvidia.com and download the driver to a known directory (~/Downloads, for example)

  2. Press Ctrl+Alt+F6 to switch to another Virtual Terminal and login with your User/Password

  3. Run sudo service lightdm stop (or Nvidia installer will not run, because there's an active X session)

  4. Run cd ~/Downloads && sudo chmod +x ~/Downloads/NVIDIA-Linux-x86_64-295.33.run (if that's the version you have downloaded, to make the installer executable)

  5. Run sudo ./NVIDIA-Linux-x86_64-295.33.run and press "OK" to all installer questions (default options)

  6. As the installer finishes, run sudo reboot now to reboot the machine.

  7. At lightdm, login to Unity 3D and verify if there was any change or improvement.

Also:

  • Make sure you are not running nouveau. You can check if nouveau is loaded by running lsmod | grep -i nouveau. It should display no results.

  • Make sure your currently loaded NVidia kernel module is the same version as the installed drivers.

  • You can check that Nvidia Kernel module is is loaded with lsmod | grep -i nv. If you installed Nvidia drivers from the proprietary/binary installer from NVidia website/FTP it should output "nvidia".

  • If you have NVidia installed from Ubuntu repos (pakage nvidia-current) it should output nvidiafb.

  • To check the Kernel module version, use modinfo nvidia or modinfo nvidiafb. It should output "version: along with other module details.

This version should match the drivers you installed.

Source

share|improve this answer
    
It didn't work. And I can't download the drivers because they're only available for windows... –  Daniel Jaló Jul 18 '12 at 15:42
    
I don't know which site you went to, but Nvidia has drivers for Linux: nvidia.com/Download/index.aspx?lang=en-us –  LnxSlck Jul 18 '12 at 22:23
    
Actually if you pick nForce series 6: nforce 630i / GeForce 7150m it only has drivers for windows... :'| –  Daniel Jaló Jul 18 '12 at 22:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.