Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

this is the first time I installed Linux so I might be doing a few things wrong. I have Asus Zenbook UX32VD, I separated the SSD and HDD, left Windows 7 on the HDD and Installed Ubuntu (12.04 x86-64) from a Pendrive.

After the installation (and also using the Live USB) screen would hardly ever work (backlight would), so I had to close and open the screen 4 or 5 times until it stayed on.

To solve this I followed these instructions, which say that you have to change quiet splash to nomodeset in the grub file. This works, except that the laptop now can't resume from suspend/standby.

I used these instructions to change the grub file, these instructions, unlike the previous say that you have to add nomodeset to quiet splash, I tried both and they both give the same results.

I also tried installing the NVIDIA drivers (x86-64 which should work for GT 620 M) but this didn't help and made the system give all kinds or errors.

Any suggestions?

EDIT: Thank you for the answer, by not resuming I mean nothing, no fan, no backlight, no keyboard backlight. I'll look at your suggestions now.

EDIT2: I found that the problem did not occur when using Ubuntu 12.10 (kernel 3.5)

share|improve this question
    
Do you have Ubuntu installed on the SSD? If so, did you move the EFI to the SSD as well? –  Nick Jul 27 '12 at 19:23
    
I did, I just used the standard config for the HDD –  bquast Jul 28 '12 at 8:35
add comment

2 Answers

You did not describe closer what "not resuming" means (no reaction at all / screen stays blank / ...) -- but the ArchLinux Wiki writes on the ASUS Zenbook UX31E for having the same problems:

The USB modules must be unloaded or the laptop will not come out of sleep mode. Put

SUSPEND_MODULES="xhci_hcd ehci_hcd uhci_hcd"

in /etc/pm/config.d/unload_module [...]

Though not being Ubuntu, this advice might help in your case. Please read the original Wiki page for full details. Also refer to this question, which also mentions some SUSPEND_MODULES issue.

share|improve this answer
    
I also found this: The solution was to add the parameter “libata.force=nohrst” to the kernel parameter command line, this causes the libata code in the kernel to no longer issue “hard resets” to the SSD when waking up, which seems totally unnecessary, anyway. (Even the “soft reset” would not be required, but that does not take a significant time.) here, but I don't really know how to do this –  bquast Jul 19 '12 at 7:07
    
that would be via the grub configuration. Check How do I add a boot parameter? to find out :) –  Izzy Jul 19 '12 at 9:04
    
Thank you. I installed Ubuntu 12.10 which did not give this problem. –  bquast Jul 19 '12 at 9:40
    
Ah, well -- that's also a possibility. Maybe you post that as answer to your own question, then accept it -- so people with the same problem can easily see it? Though not all of them probably want to go for some "early bird", or even a non-LTS, for some it may be acceptable. –  Izzy Jul 19 '12 at 9:44
add comment
up vote 1 down vote accepted

Installing Ubuntu 12.10 solved the problem for me. I guess this is due to kernel 3.5, so perhaps you could also just update this.

EDIT: I wrote this above when I was using the Alpha version which ran on 3.5.0-4-generic. As soon as I upgraded to the beta 1 the problem returned. However I uninstalled the 3.5.0-18-generic kernel so that it always uses 3.5.0-4-generic.

EDIT2: I edited the grub file: replace quiet splash with nomodeset

share|improve this answer
    
I still have this problem in 12.10 –  Andrei Oct 23 '12 at 12:41
    
I have edited, hope this helps –  bquast Oct 24 '12 at 7:46
    
I will see if it has any effect. Thank you. –  Andrei Oct 24 '12 at 12:29
    
I also replaced quiet splash with nomodeset, let me know if you don't know how –  bquast Oct 24 '12 at 15:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.