Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded my PC to the following Spec:

  • Processor: Intel Core i5-3470
  • Motherboard: GA-B75M-D3H - GIGABYTE B75M-D3H IVY BRIDGE MOTHERBOARD
  • RAM: JM1333KLN-4G - TRANSCEND 4GB JETRAM DDR3 1333 DIMM 9-9-9
  • HDD: ST31000524AS - SEAGATE 1TB 3.5"HDD 7200RPM SATA 6GB/S 32MB CACHE
  • Graphics Card: Using the onboard graphics

When installing Ubuntu 12.04, all the boxes shown on screen as well as the menu bar across the top are corrupted. It seems to be a 3d related issue because 2d items such as pictures display in the install window and/or icons are ok during the install.

I can upload pictures later but basically all the boxes look as if they have horizontal and vertical tears/pixelation. The edges which are supposed to have a nice shadow effect are also all choppy and jagged. Text on the boxes is barely visible and as the text updates different letters become partially visible.

It was a bit difficult but I managed to setup my Wi-Fi (for updates) and complete the install.

When booting the background image displays as does the mouse cursor but then the screen just flickers a few times before turning off completely.

Pressing Ctrl-Alt-F1 gets me to the terminal prompt and I was able to run: $sudo apt-get update $sudo apt-get upgrade

After installing 305 updates the issue was still not resolved.

Does anybody have any ideas?? I also tried the 12.10 daily build but the Kernel crashed during install

I'm new to Ubuntu but so far this is really disappointing, I was hoping to use this PC for some development projects I had in mind but it doesn't work out the box! I also don'thave unlimited bandwidth so I can't keep downloading updates all the time.

Windows 7 worked just fine....

share|improve this question
add comment

4 Answers 4

up vote 0 down vote accepted

Finally a patch to fix this issue has been committed and the updated package (xserver) is now downloadable through package manager! I myself also confirmed this and it just works without the workaround of "nomodeset".

share|improve this answer
add comment

This is a known bug. A patch has been submitted though it has not yet made it in to the official repo. You can get the updated files using the developer's PPA and following the instructions below:

  1. Do a fresh install of 12.04, boot installer with nomodeset

  2. On first boot add nomodeset in GRUB (hold shift on boot, press 'e' to edit)

  3. Open a Terminal and type sudo add-apt-repository ppa:tjaalton/ppa

  4. Run apt-get dist-upgrade

  5. Reboot

Note: I've found that upgrading the kernel to 3.6-rc1 breaks the Intel driver, it also seems to be incompatible with the xorg-edgers packages.

share|improve this answer
add comment

It seems like you have exactly the same problems with mine including the processor (i5 3470) and the mother board as well. The solution that I found yesterday is to disable kernel mode setting feature by adding an kernel command line option nomodeset. You can temporarily edit the command line in grub boot menu and if it works, you're going to make it permanent by editing grub configuration.

share|improve this answer
    
Thanks for the info - this fixed the issue with the installer but then I ran into the same issues when the system booted. Will try the nomodeset as part of Grub again now then... –  undercoverMunky Aug 1 '12 at 21:27
    
The nomodeset worked well, thanks a lot! I just need to sort out the GPU hangs now but I think the other answers are pointing me in the right direction –  undercoverMunky Aug 3 '12 at 8:47
add comment

if you can login : Firstly, Open terminal and type:

  1. sudo add-apt-repository ppa:ubuntu-x-swat/x-updates

  2. Followed by sudo apt-get update

  3. And sudo apt-get install xserver-xorg-video-intel

This will install INTEL latest drivers. Just reboot once installed and look for changes that have taken place.

If this does not work then try this testing PPA repository:

Open terminal type in:

  1. sudo add-apt-repository ppa:intel-gfx-testing/ppa
  2. Followed by sudo apt-get update

Once you are done, reboot and try to change resolution you are looking for.

share|improve this answer
    
Tired this and unfortunately it never worked, I also tried the XOrg Edgers repo's also with no luck. I do notice though that the i915 GPU hangs quite often, with the edgers updates its less frequent but still happens a lot –  undercoverMunky Aug 1 '12 at 21:29
    
If you want to install software from ppa:intel-gfx-testing/ppa (or any PPA), it's not enough just to enable the PPA and run sudo apt-get update. You must actually upgrade to the versions provided, which you can usually do in the Update Manager or by running sudo apt-get upgrade or (if that's insufficient) sudo apt-get dist-upgrade. However, this particular PPA has no software for any version of Ubuntu past 9.10. xorg-edgers can be used instead for some packages. –  Eliah Kagan Aug 2 '12 at 16:02
    
Adding a file /usr/share/X11/xorg.conf.d/20-intel.conf with this content: Section "Device" Identifier "Intel Graphics" Driver "intel" Option "SwapbuffersWait" "False" Option "RelaxedFencing" "False" EndSection seemed to fix intel graphics stability problems for me. I have Levono T500 with Intel GM45 Express (i965) graphics. –  FlareCoder Aug 3 '12 at 7:26
    
@EliahKagan - I did run the upgrade immediately after adding the PPA. Unfortunately it seems like there are no updates available from intel-fx-testing since I am also using the xorg-edgers. –  undercoverMunky Aug 3 '12 at 8:45
    
@FlareCoder - That sounds like some good info, I'll try it out as soon as I get a chance, stuck at work now unfortunately –  undercoverMunky Aug 3 '12 at 8:48
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.