Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have virtualbox installed on Ubuntu 12.04 LTS (host) with ubuntu 10.04 LTS as a VM (guest). The VM has guest additions installed.

I'd like to be able to reliably use alt-tab to switch windows within the guest, at least when I am in full-screen mode. Instead what I currently get is that sometimes it switches windows in the guest, sometimes it switches windows in the host system, sometimes it activates the HUD in the host and sometimes it does more than one of these three things at the same time.

What can I do so that when I am working on the guest only the guest responds to alt-tab? (I have a similar problem with the super key--though that isn't as much of an issue since 10.04 doesn't make as much use of it.)

share|improve this question
    
Possible duplicate? askubuntu.com/questions/140497/… –  fossfreedom Jul 18 '12 at 6:32
    
Thanks fossfreedom for pointing me to that. I hadn't seen it, and it is interesting. In answer to your question, I don't think this is a duplicate since the solution to that problem was to enable "Auto capture keyboard" and in my case it is already enabled. –  snowguy Jul 18 '12 at 15:58
1  
This question has the right solution: askubuntu.com/questions/122209/…. –  Rörd Nov 22 '12 at 6:50
    
@sownguy Did you find a solution to this problem? –  user785287 Mar 31 at 23:32
    
no I did not :( –  snowguy Apr 2 at 1:36

2 Answers 2

Using right Ctrl you can move between real OS and Virtual for the shortcuts. So every time you hit that button, you change between VM and the real machine and there is where the shortcut will apply.

The default desktop that a shortcut applies when you open a VM in full screen i think its a little bit random. Sometimes inside the VM, sometimes on the real desktop.

share|improve this answer

You may also want to completely disable the HUD hotkey. I do this because I spent most of my time inside VMs and not on the host desktop.

How do I modify or disable the HUD's use of the Alt key?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.