Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running precise pangolin on my laptop and always keep it updated. I've had some problems with the cdrom not being recognized by K3b before, but got it fixed by changing the permissions. But this time it seems that it is totally vanished from my computer. I've tried many different things that users had suggested on this website and many other websites, but none seems to work. Ironically, it works just fine when I boot to windows.

Here is the output of some commands:

$ sudo wodim --devices
wodim: Overview of accessible drives (0 found) :
-------------------------------------------------------------------------
-------------------------------------------------------------------------

and

 $ sudo depmod -ae

doesn't seem to do any good for me.

Also, for some reason there was no /dev/cdrom or /dev/cdroms or /dev/dvdrom folder on my computer. Nothing even similar to that.

My fstab looked like this:

proc            /proc           proc    nodev,noexec,nosuid 0       0
UUID=50424cf6-6dd8-4d34-a441-dd964f67ea97 /               ext4    errors=remount-ro 0       1
UUID=ebf67e0f-3597-4ed9-bedc-73a4e8049071 /boot           ext4    defaults        0       2
UUID=e22d709a-c084-4fbf-bad3-2fef352e7e75 /home           ext4    defaults,user_xattr        0       2
UUID=94ca0e7c-e4bc-43b6-993f-fd140b6db7bd none            swap    sw                  0       0

and I added different things like the following:

 /dev/cdrom /mnt/cdrom iso9660 noauto,ro 0 0

but none of them helped.

And finally

$ dmesg | grep cdrom

returns nothing.

I'm not very familiar with technical things, I just tried all the different things suggested by others. Any help would be appreciated.

--

There are nothing related to cdrom in lshw, but in the output there are some unclaimed things:

$ sudo lshw
*-core
  [...]
  *-pci
    [...]
    *-serial UNCLAIMED
         description: SMBus
         product: 82801H (ICH8 Family) SMBus Controller
         vendor: Intel Corporation
         physical id: 1f.3
         bus info: pci@0000:00:1f.3
         version: 03
         width: 32 bits
         clock: 33MHz
         configuration: latency=0
         resources: memory:a0100000-a01000ff ioport:1c20(size=32)
 *-remoteaccess UNCLAIMED
   vendor: Intel
   physical id: 1
   capabilities: inbound

I'm not sure if it is something related or not!

share|improve this question
    
What about sudo lshw? Can you see any cdrom related entry? –  Eric Carvalho Jul 18 '12 at 2:27
    
@EricCarvalho, Nothing related to cdrom. But there are a few UNCLAIMED things there. I added them to the original post. –  Keivan Jul 18 '12 at 19:00
    
If you don't mind I'd like to see your dmesg. Open /var/log/dmesg, copy its content and paste it on paste.ubuntu.com . Post here the pastebin URL (e.g. paste.ubuntu.com/1234567). –  Eric Carvalho Jul 18 '12 at 20:52
    
Sure, here it is: paste.ubuntu.com/1099213 –  Keivan Jul 18 '12 at 23:25
    
Thanks for the help @EricCarvalho. I can't really use that method on my laptop though. –  Keivan Aug 3 '12 at 17:12

1 Answer 1

I google it and found a lot of similar problems, most of them with no solution. But a couple of guys managed to solve this problem by changing the SATA port connected to the CD-ROM.

https://bbs.archlinux.org/viewtopic.php?id=125686

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.