Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently installed AwesomeWM, everything was going fine til I tried to edit the rc.lua. It wouldn't let me save from AwesomeWM so I opened up Unity and saved it from there and when I tried to log back into Awesome it just keeps throwing me back to the lightdm login screen.

I have tried sudo apt-get remove awesomeand then reinstalling it. I have tried getting a working rc.lua from google and neither of these work.

I don't really know what to do. It just keeps throwing me back to the login box, unity and 2d are both working fine. Very strange inded.

share|improve this question

When you tried editing rc.lua, were you trying to edit the system-wide one? I'm guessing you didn't have proper permission to do so and then in Unity you used some GUI method that got around that. That might have messed up the permissions on the config file so that you can't use it on login; either that, or there's a serious error in your config, although I've never had such a bad error it won't let me login.

Make sure you copy the default system-wide rc.lua to ~/.config/awesome/:

cp /etc/xdg/awesome/rc.lua ~/.config/awesome/

Then edit the local copy. By the way, just because you got someone's rc.lua doesn't mean it will work for you. It depends how much they've customized it. After modifying your rc.lua, you should always run awesome -k first, before restarting Awesome. This will check for basic errors in your configuration, although it's not a perfect check.

share|improve this answer


awesome -k 

reports no errors, i'd try

sudo dpkg-reconfigure --force lightdm awesome
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.