Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been USB tethering with my Nexus S for over a year with no problems. Went on vacation last week, came back, and discovered tethering no longer works.

The phone actually thinks its tethered just fine and shows the tethering icon in the top menu bar as normal. But Ubuntu's connection icon in the top right sys tray just sits there spinning, unable to complete the connection.

I also tried Wireless Hotspot and Bluetooth, but neither seems to work either (Hotspot has always worked in the past, never tried Bluetooth tethering till today). Normal wireless routers (home, library, starbucks, etc.) still work fine, it's just connecting to my phone that appears broken.

No idea what's the problem, a recent update maybe?

share|improve this question

closed as off topic by Christopher Kyle Horton, RolandiXor, James Aug 15 '12 at 18:43

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

Thank you for reporting this bug! Unfortunately, questions about bugs are considered offtopic for Ask Ubuntu, and this question should be closed. Glad to hear that your issue has since been resolved, however. – Christopher Kyle Horton Jul 28 '12 at 4:23
up vote 1 down vote accepted

Update: Also fixed in latest kernel upgrade (3.2.0-27-generic).

This appears to be a kernel regression from 3.2.0-25-generic to 3.2.0-26-generic. Reverting to the older kernel solved it. Bug reported.

share|improve this answer

protected by RolandiXor Jul 28 '12 at 5:24

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.