Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Linux/Ubuntu rookie here, so please be patient, and thank you in advance for any help!

I recently installed Ubuntu 12.04 Server 32-bit on my old Dell Dimension E310. When I boot it up, it takes me to the GRUB bootloader, and I select the 12.04 Server option. After that, things are slightly inconsistent. Usually, I will see some of the text fly through on the screen as it's loading it all up, and then the whole machine suddenly reboots without ever fully loading. Sometimes, it will be a black screen for a few seconds, and then restart. And rarely, it will be black, and just hang up indefinitely until I have to force a shutdown.

If I boot into recovery mode from GRUB, and then once at the recovery screen select normal and continue on, everything works just fine, and I can get on and use the server as expected.

At first, I ended up just reformatting the entire drive and doing a completely fresh install, this time with a CD instead of the USB, but I still get the same issue.

Also, to add to the mystery, before I had 12.04 Server, I had 12.04 Desktop doing the exact same thing. 12.04 Desktop is still installed on the second hard drive in the server if that's relevant, but I eventually plan to clear that all off, so I'm only looking to get 12.04 Server running. To clarify, Server is on one hard drive, Desktop is on the other.

Please let me know if there is any additional information I can provide to help diagnose or solve the issue! I'm new, but I'm motivated to learn. :) Just a bit stumped at the moment! Thanks again!

share|improve this question
    
go to grub highlight "12.04 server" press "e" the text that shows up will be helpful. Also if possible the last text you see before it reboots –  Matt Mootz Jul 17 '12 at 21:28
    
After the Dell screen, right before the GRUB screen loads, it quickly flashes: error: fd0 read error. Hitting "e" when highlighting the 12.04 Server option on GRUB gives: setparams 'Ubuntu, with Linux 3.2.0-26-generic-pae' recordfail gfxmode $linux_gfx_mode insmod gzio insmod part_msdos insmod ext2 set root='(hd1,msdos1)' search --no-floppy --fs-uuid --set=root 90b7908e-5862-40b4-8aab-ab4ad68117fe9 linux /vmlinuz-3.2.0-26-generic-pae root=/dev/mapper/Server-root to initrd /initrd.img-3.2.0-26-genericpae –  stefprez Jul 17 '12 at 21:53
    
The last lines before reboot are either: Begin: Running /scripts/local-bottom ... done. done. and Begin: Running /scripts/init-bottom ... done. Or something about Dell USB Mouse on usb-0000:00:1d.0-2/input0 done. –  stefprez Jul 17 '12 at 21:56
    
I added quiet splash nomodeset to the end of the line that says linux /vmlinuz-..., and it booted successfully. This means it has to be related to the graphics driver. I've already installed the nvidia-current package which didn't fix the issue. I have a GeForce FX 5200 Nvidia graphics card. Any help, as well as any insight as to why sticking with this nomodeset bandaid is a bad idea would be greatly appreciated! –  stefprez Jul 18 '12 at 6:03

1 Answer 1

Some googling I have some mixed reviews on the support on that card in 12.04. This question seemed to offer a alternative driver solution.

http://askubuntu.com/a/139986/7077

You might need to find a more supported card

http://www.nvidia.com/object/linux-display-ia32-295.59-driver.html

for a more recent card if the other method dosent work.

If you plan to use it as a server and not install x or use a GUI I don't think it will be a problem using the "nomodeset". But if you wanted to login with VNC or use the GPU for something I would recommend buying a more supported card.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.