Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'd like to disable hardware buttons on the synaptic touchpad, but still be able to use the touchpand and "tap"-click on its surface. I don't find the related options in the output of synclient -l.

Note that I don't want to disable the touchpad completely. Only to make it ignore the hardware buttons, but still respond to taps.

share|improve this question
    
What you get when you type synclient -l in terminal. –  karthick87 Dec 7 '10 at 10:52
    
pastebin.com/bcgKwqyG –  sastanin Dec 7 '10 at 11:24
    
I have updated my answer,have a look at it. –  karthick87 Dec 7 '10 at 12:32
1  
My question is not how to disable it completely, only how to disable its hardware buttons. –  sastanin Dec 7 '10 at 23:07
1  
This should be retagged with synaptics; synaptic (without the final s) is the graphical package manager that comes with Ubuntu, while Synaptics is a type of touchpad. –  dgw Dec 16 '10 at 1:58

3 Answers 3

Disabling Touchpad:

Press ALT+F2 and type gconf-editor and click Run.
alt text
Navigate to desktop>gnome>peripherals>touchpad,in the right panel uncheck the entry touchpad_enabled.
alt text
Now your tochpad will be disabled.

To turn of touchpad completely:
To turn of touchpad completely install gpointing-device-settings Install gpointing-device-settings after installation you can access it under System >>Preferences>>Touchpad

UPDATE:

FYI:
Also See this tutorial on disabling touchpad.
How to disable/enable touchpad in Ubuntu

share|improve this answer
2  
Thank you, but I'd like not to disable the touchpad completely. Only to make it ignore the hardware buttons, but still respond to taps. –  sastanin Dec 7 '10 at 11:23
1  
I suggest you file against gpointing-device-settings; this doesn't seem to be currently possible. –  poolie Apr 20 '11 at 0:35
    
Thank you, @poolie, I filed this as bugs.launchpad.net/ubuntu/+source/gpointing-device-settings/…. I you wrote this as an answer, I'd be able to accept it. –  sastanin Jun 6 '11 at 10:11

This will disable the hardware buttons and the "tap" feature, but you will be able to move the pointer:

1) Create this file:

gedit ~/.Xmodmap  

2) Paste this into it:

pointer = 0 0 0  

3) Logout and log back in, or reboot, or run this:

xmodmap ~/.Xmodmap  

To get it back to normal:

1) Edit the file:

gedit ~/.Xmodmap  

2) And change to:

pointer = default  

3) Logout and log back in, or reboot, or run this:

xmodmap ~/.Xmodmap  

4) If this file doesn't have anything else, then you can delete it after step "3":

rm ~/.Xmodmap  
share|improve this answer
1  
Won't this disable mouse clicks altogether, regardless of origin? –  poolie Apr 14 '11 at 2:03
    
:-/ You probably right, I will check that when I get to my computer (I'm on mobile now). –  desgua Apr 14 '11 at 10:35
    
Were you able to check whether this worked? –  belacqua Apr 17 '11 at 1:35
    
Sorry. It disables the hardware buttons AND the touchpad tap. I am searching for a better solution. –  desgua Apr 17 '11 at 1:54
up vote 1 down vote accepted

Filed a bug against gpointing-device-settings #793440. It seems impossible to do what I want with the current version of the software. Question closed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.