Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On 12.04 LTS, I typed "apt-get install xdm" - then a window asked if I wanted lightdm or xdm, and I selected xdm. Then I rebooted but the display only showed, for a very long time, the word "ubuntu" and orange dots moving over a purple background. There was no login prompt. I was not able to use key sequences such as Ctrl-Alt-F1 to Ctrl-Alt-F7 (or Alt-F1 to Alt-F7) to obtain a text terminal. All of these key sequences were ignored. I rebooted multiple times and this behavior always occurs. What is the easiest way to obtain login access to the system?

share|improve this question
    
Press "esc" while the Ubuntu splash screen is showing to see what fails. –  Dymatic Jul 17 '12 at 20:12
    
The last two lines are "Starting X display manager xdm [OK]" and "Stopping System V runlevel compatibility [OK]." All of the "[]" are "[OK]." The only part that looks like possibly an error message is "Starting CUPS printing spooler/server [OK]" followed by "could not write bytes: Broken pipe." After showing this output in response to the "esc" key, the system seems hung (or at least I don't know what other keyboard input I should use). –  Judy Jul 17 '12 at 20:34

3 Answers 3

Reboot the computer and keep the SHIFT key pressed in order to access the boot options. Select "recovery mode". This should allow you to login in your system again.

share|improve this answer
    
The underlying problem might be a bug in /etc/init/plymouth-stop.conf in which the line that begins with gdm|kdm ought to begin with xdm|gdm|kdm instead. I do not have permission to self-answer, but may try to self-answer after waiting the required number of hours. –  Judy Jul 17 '12 at 22:40
up vote 1 down vote accepted

Trying to change a 12.04 LTS system from LightDM to xdm by installing the xdm package and then running dpkg-reconfigure lightdm to select xdm apparently does not work.

The failure mode is that a normal boot hangs forever on the "orange dots - purple background" screen, and it is necessary to use recovery mode to access the system. One or both of these other two steps will apparently fix the problem:

  • delete the /etc/init/lightdm.conf file and/or
  • edit the /etc/init/plymouth-stop.conf file, locate the line beginning with gdm|kdm and change this line to begin with xdm|gdm|kdm instead.

I most likely will not research this further and most likely will not submit a bug report myself. I do not know whether either of the steps mentioned above is considered a supported or recommended configuration change. Also, I do not know whether use of xdm is considered a supported activity on 12.04 LTS.

share|improve this answer
    
Good point Judy... I had the same issue and I solved reinstalling gdm –  tmow Oct 16 '12 at 21:40

Same problem happened to me.

Go to tty1 with Control + Alt + F1. Then I ran

lightdm 

from there.The login screen appeared this time.Also I will try to apply the fix listed above

edit the /etc/init/plymouth-stop.conf file, locate the line beginning with gdm|kdm and change this line to begin with xdm|gdm|kdm instead.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.