Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed a second internal hard drive. I have read help various help files on mounting via fstab file. After running the mount -a command. The partition is mounted /mnt/films. But when i select the folder i can't do anything. I'm informed that i'm not the root user, and have no permissions. (I am a complete beginner learning mode one step at a time) ubuntu oneric

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc                                       /proc  proc  nodev,noexec,nosuid  0  0  
# / was on /dev/sda1 during installation
UUID=4810412d-43db-477a-b6f2-8f2948924d90  /      ext4  errors=remount-ro    0  1  
# swap was on /dev/sda5 during installation
UUID=967bd3d5-32e5-4f20-9095-446047353d21  none   swap  sw                   0  0  
#

# /dev/sdb1 is Seagate Barracuda 2TB
UUID=a35d1e8d-4461-4e33-abf7-edea029d7ae5 /mnt/Films    ext4    rw,sync,user     0 0
share|improve this question
    
Suggested edit: Corrected typo in title and added tag for fstab –  Julian Knight Jul 18 '12 at 13:42

1 Answer 1

You should create the folder /mnt/films using the command (in a terminal):

sudo mkdir /mnt/films

Then you need to change permissions so that you have read access to the folder:

sudo chown root:users /mnt/films

This allows group use by the users group which your logged in user should be a member of (it will be as standard). So make sure that the group permissions include read and write:

sudo chmod g+rw /mnt/films

If ther are folders and/or files already on the drive, you may need to adjust their ownership and permissions too.

I assume that you have formatted the drive as ext4? By default it probably came formatted as FAT32.

share|improve this answer
    
Also, if you are just starting out with Ubuntu, you are probably better off using the latest release (12.04) if you can. –  Julian Knight Jul 17 '12 at 19:25
    
Thanks Julian. I will read up on the chmod command, and it options. I did format the drive as ext4. Was I Wrong? Can you point out what mistake I made in editing the fstab file. I will install ubuntu 12.04 after I have learnt how to add additional drives in the fstab. Will keep you informed. –  Peter Jul 18 '12 at 22:31
    
One question - how big is the drive? There can be issues with drives >2.1TB. Other than that, the fstab entry looks ok & ext4 is fine so nothing there. That's why I kind of assume it must be a permissions issue. –  Julian Knight Jul 19 '12 at 9:02
    
Hi Justin, I have installed ubuntu 12.04. I have edited the fstab file, and have my 2tb internal sata drive mounting in /mnt/films. When i go in to the directory of films. There is a folder call lost+found, and it only has user permissions drwx------ 2 root. To gain access rights/have the same access rights as the root. Using chmod, do i need to make changes to access rights of the group of this file eg. drwxrwx---. My aim is to have a directory on that 2tb drive that i can store all my films. Your help is much appreciated. –  Peter Jul 22 '12 at 10:57
    
Hi Julian, sorry for getting your name wrong in my previous post. Such a massive learning curve for me and my brain. I have re read your answer. Which has answer my question. Sorry. –  Peter Jul 23 '12 at 7:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.