Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I first got my laptop, Unity 3D worked fine. Then, suddenly, it stopped. Then, regardless of which desktop environment I chose, it booted Unity 2D. I tried installing my ATI/AMD graphics drivers, and only the non-post-release on installs. That doesn't even fix the issue.

Assuming it was an issue with Unity, I installed Gnome 3. To my surprise, the same issue occurred again! When I told it to boot Gnome, it went to Gnome Classic. Please help me! I would really like to have Ubuntu up and running on my laptop before I start college.

share|improve this question
    
I don't know about why Unity 3D stopped working for you but Gnome-shell is not compatible with many ATI graphics card. For instance, I have ATI Mobility Radeon HD 550v and gnome-shell display is all pink/purple/white lined. –  Akshit Baunthiyal Jul 17 '12 at 17:03

3 Answers 3

This problem is ocurring because the graphic cards 3D capability aren't enabled. You must enable them to get full 3D.

What are the results of:

/usr/lib/nux/unity_support_test -p

and

glxinfo

share|improve this answer

I think it's similar to my problem.

I can't login in Unity 3D and GNOME 3 if my local network is turned on but cable isn't connected. Try to turn off the network in network-manager and then restart your laptop, login in Unity 3D. I hope it works for you.

share|improve this answer

It's similar for me. A few minutes ago I've updated some packages of Gnome Classic and after that when I exited from my session Unity 3D and Gnome Classic didn't work anymore. But Unity 2D and Gnome Shell ran fine.

First, I thought that ATI drivers crashed. So I uninstalled it but nothing changed.

Tomorrow I'll see if there are changes (via update manager) and if not, I'll do a Unity reset, hope this works.


UPDATE:
Solved, again in Unity 3D. The commands

sudo gconftool --recursive-unset /apps/compiz-1
sudo gconftool --recursive-unset /apps/compizconfig-1

didn't work for me. So the solution was a unity --reset.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.