Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 12.04 LTS. This morning when I logged into my Ubuntu, after login screen the complete desktop was empty, the only operation I could perform is right-click and open terminal.

What I've tried:

  1. Ctrl+Alt+F1 unity --reset : didn't work
  2. From terminal unity --reset : didn't work
  3. And from login screen selecting Ubuntu 2D and that also didn't solve the problem.

My laptop is Toshiba SA-60 onboard ATI graphic card with 1 GB RAM.

Please tell me how to solve this problem. I don't want to reinstall Ubuntu as whenever I install a I/O error pops up, forget about that. I don't want to reinstall Ubuntu. Please help.

share|improve this question
    
I accidentally removed python, after that ubuntu-desktop dissapeared, I didn't have an access to standart terminal. Thankful to this post I ran Ctrl+Alt+F1 and installed ubuntu-desktop directly by command sudo apt-get install ubuntu-desktop –  klimat Mar 15 '13 at 14:09
add comment

4 Answers 4

  • Install gnome-tweak-tool.
sudo apt-get install gnome-tweak-tool
  • Go to Desktop list item. Make sure Have file manager handle the desktop is turned ON.

    enter image description here

share|improve this answer
    
Thanks a lot. Sometimes something strange can happen. Unity --reset says "this should never happen... report a bug". But help of community makes a difference. –  SChepurin Apr 13 '13 at 12:46
    
Glad it helped. –  green7 Apr 13 '13 at 12:47
    
thanks it is the real solution :) –  Abhishek Goel Feb 23 at 20:51
add comment

The answer is kind of weird. Because you have tried the right things to reset unity.

Lets try once again,

Press Alt+Ctrl+F1, login and then enter these commands one by one.

sudo lightdm stop

gconftool-2 --recursive-unset /apps/compiz-1

unity --reset-icons

unity --reset

Have you played with any config file, x org configuration last time?

sudo reboot now

share|improve this answer
    
dude its not happening, its giving errors n i can't even post them –  sunny Jul 17 '12 at 17:21
add comment

I had the same problem and I was unable to reset unity. I finally solved by reinstalling libgrail5:

sudo apt-get install --reinstall libgrail5
share|improve this answer
add comment
sudo apt-get install --reinstall libgrail5

I have tried all the unity re-installs even going back to gnome. this took me 3 hours , but above command did the trick. My mistake was to tweak compiz, i know they give warnings ,but we run linux so what do you expect.

Precise desktop wallpaper no icons or anything I was ready to reinstall ,but still i did like to know I am not a geek or a newbie but something in between.

regards

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.