Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having a problem , when I try to install or upgrade something, it appears like it fails, but it does not.

This will pop up usually only for the Ubuntu Software Center.

Image 1

This will pop up after installing for upgrading anything.

Image 2

Yet the program still works (well, this one didn't really. But it installed fine for as long as I kept it installed.)

Image 3

This isn't a big deal since the programs install fine. But the errors are still annoying.

Update: When I manually, refresh the update manager, an error pops up but it still works. Update: When doing an update, this is the error I got

installArchives() failed: (Reading database ... 
(Reading database ... 5%%
(Reading database ... 10%%
(Reading database ... 15%%
(Reading database ... 20%%
(Reading database ... 25%%
(Reading database ... 30%%
(Reading database ... 35%%
(Reading database ... 40%%
(Reading database ... 45%%
(Reading database ... 50%%
(Reading database ... 55%%
(Reading database ... 60%%
(Reading database ... 65%%
(Reading database ... 70%%
(Reading database ... 75%%
(Reading database ... 80%%
(Reading database ... 85%%
(Reading database ... 90%%
(Reading database ... 95%%
(Reading database ... 100%%
(Reading database ... 315343 files and directories currently installed.)
Preparing to replace libgstreamer-plugins-base0.10-0 0.10.36-1 (using .../libgstreamer-plugins-base0.10-0_0.10.36-1ubuntu0.1_i386.deb) ...
Unpacking replacement libgstreamer-plugins-base0.10-0 ...
Preparing to replace ubuntu-sso-client-gtk 3.0.0-0ubuntu2 (using .../ubuntu-sso-client-gtk_3.0.2-0ubuntu1_all.deb) ...
Unpacking replacement ubuntu-sso-client-gtk ...
Preparing to replace ubuntu-sso-client 3.0.0-0ubuntu2 (using .../ubuntu-sso-client_3.0.2-0ubuntu1_all.deb) ...
Unpacking replacement ubuntu-sso-client ...
Preparing to replace python-ubuntu-sso-client 3.0.0-0ubuntu2 (using .../python-ubuntu-sso-client_3.0.2-0ubuntu1_all.deb) ...
Unpacking replacement python-ubuntu-sso-client ...
Preparing to replace python-problem-report 2.0.1-0ubuntu8 (using .../python-problem-report_2.0.1-0ubuntu11_all.deb) ...
Unpacking replacement python-problem-report ...
Preparing to replace python-apport 2.0.1-0ubuntu8 (using .../python-apport_2.0.1-0ubuntu11_all.deb) ...
Unpacking replacement python-apport ...
Preparing to replace apport 2.0.1-0ubuntu8 (using .../apport_2.0.1-0ubuntu11_all.deb) ...
apport stop/waiting
Unpacking replacement apport ...
Preparing to replace apport-gtk 2.0.1-0ubuntu8 (using .../apport-gtk_2.0.1-0ubuntu11_all.deb) ...
Unpacking replacement apport-gtk ...
Preparing to replace firefox-globalmenu 13.0.1+build1-0ubuntu0.12.04.1 (using .../firefox-globalmenu_14.0.1+build1-0ubuntu0.12.04.1_i386.deb) ...
Unpacking replacement firefox-globalmenu ...
Preparing to replace firefox 13.0.1+build1-0ubuntu0.12.04.1 (using .../firefox_14.0.1+build1-0ubuntu0.12.04.1_i386.deb) ...
Unpacking replacement firefox ...
Preparing to replace firefox-gnome-support 13.0.1+build1-0ubuntu0.12.04.1 (using .../firefox-gnome-support_14.0.1+build1-0ubuntu0.12.04.1_i386.deb) ...
Unpacking replacement firefox-gnome-support ...
Preparing to replace firefox-locale-en 13.0.1+build1-0ubuntu0.12.04.1 (using .../firefox-locale-en_14.0.1+build1-0ubuntu0.12.04.1_i386.deb) ...
Unpacking replacement firefox-locale-en ...
Preparing to replace firefox-locale-zh-hans 13.0.1+build1-0ubuntu0.12.04.1 (using .../firefox-locale-zh-hans_14.0.1+build1-0ubuntu0.12.04.1_i386.deb) ...
Unpacking replacement firefox-locale-zh-hans ...
Preparing to replace gstreamer0.10-alsa 0.10.36-1 (using .../gstreamer0.10-alsa_0.10.36-1ubuntu0.1_i386.deb) ...
Unpacking replacement gstreamer0.10-alsa ...
Preparing to replace gstreamer0.10-gnomevfs 0.10.36-1 (using .../gstreamer0.10-gnomevfs_0.10.36-1ubuntu0.1_i386.deb) ...
Unpacking replacement gstreamer0.10-gnomevfs ...
Preparing to replace gstreamer0.10-plugins-base 0.10.36-1 (using .../gstreamer0.10-plugins-base_0.10.36-1ubuntu0.1_i386.deb) ...
Unpacking replacement gstreamer0.10-plugins-base ...
Preparing to replace gstreamer0.10-plugins-base-apps 0.10.36-1 (using .../gstreamer0.10-plugins-base-apps_0.10.36-1ubuntu0.1_i386.deb) ...
Unpacking replacement gstreamer0.10-plugins-base-apps ...
Preparing to replace gstreamer0.10-x 0.10.36-1 (using .../gstreamer0.10-x_0.10.36-1ubuntu0.1_i386.deb) ...
Unpacking replacement gstreamer0.10-x ...
Preparing to replace thunderbird-globalmenu 13.0.1+build1-0ubuntu0.12.04.1 (using .../thunderbird-globalmenu_14.0+build1-0ubuntu0.12.04.1_i386.deb) ...
Unpacking replacement thunderbird-globalmenu ...
Preparing to replace thunderbird 13.0.1+build1-0ubuntu0.12.04.1 (using .../thunderbird_14.0+build1-0ubuntu0.12.04.1_i386.deb) ...
Unpacking replacement thunderbird ...
Preparing to replace thunderbird-locale-en 1:13.0.1+build1-0ubuntu0.12.04.1 (using .../thunderbird-locale-en_1%%3a14.0+build1-0ubuntu0.12.04.1_i386.deb) ...
Unpacking replacement thunderbird-locale-en ...
Preparing to replace thunderbird-locale-en-us 1:13.0.1+build1-0ubuntu0.12.04.1 (using .../thunderbird-locale-en-us_1%%3a14.0+build1-0ubuntu0.12.04.1_all.deb) ...
Unpacking replacement thunderbird-locale-en-us ...
Preparing to replace xul-ext-ubufox 2.0.3-0ubuntu1 (using .../xul-ext-ubufox_2.1.1-0ubuntu0.12.04.1_all.deb) ...
Unpacking replacement xul-ext-ubufox ...
Processing triggers for shared-mime-info ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Processing triggers for hicolor-icon-theme ...
Processing triggers for man-db ...
Processing triggers for ureadahead ...
ureadahead will be reprofiled on next reboot
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Setting up oracle-java7-installer (7u3-0~eugenesan~precise4) ...
Downloading...
--2012-07-18 11:03:46--  http://download.oracle.com/otn-pub/java/jdk/7u3-b04/jdk-7u3-linux-i586.tar.gz
Resolving download.oracle.com (download.oracle.com)... 63.97.123.18, 63.97.123.8
Connecting to download.oracle.com (download.oracle.com)|63.97.123.18|:80... connected.
HTTP request sent, awaiting response... 302 Moved Temporarily
Location: https://edelivery.oracle.com/otn-pub/java/jdk/7u3-b04/jdk-7u3-linux-i586.tar.gz [following]
--2012-07-18 11:03:46--  https://edelivery.oracle.com/otn-pub/java/jdk/7u3-b04/jdk-7u3-linux-i586.tar.gz
Resolving edelivery.oracle.com (edelivery.oracle.com)... 23.13.178.174
Connecting to edelivery.oracle.com (edelivery.oracle.com)|23.13.178.174|:443... connected.
HTTP request sent, awaiting response... 302 Moved Temporarily
Location: http://download.oracle.com/errors/download-fail-1505220.html [following]
--2012-07-18 11:03:47--  http://download.oracle.com/errors/download-fail-1505220.html
Connecting to download.oracle.com (download.oracle.com)|63.97.123.18|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 5307 (5.2K) [text/html]
Saving to: `./jdk-7u3-linux-i586.tar.gz'

     0K .....                                                 100%%  468K=0.01s

2012-07-18 11:03:48 (468 KB/s) - `./jdk-7u3-linux-i586.tar.gz' saved [5307/5307]

Download done.
sha256sum mismatch jdk-7u3-linux-i586.tar.gz
Oracle JDK 7 is NOT installed.
dpkg: error processing oracle-java7-installer (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
Setting up libgstreamer-plugins-base0.10-0 (0.10.36-1ubuntu0.1) ...
Setting up python-ubuntu-sso-client (3.0.2-0ubuntu1) ...
Setting up ubuntu-sso-client (3.0.2-0ubuntu1) ...
Setting up ubuntu-sso-client-gtk (3.0.2-0ubuntu1) ...
Setting up python-problem-report (2.0.1-0ubuntu11) ...
Setting up python-apport (2.0.1-0ubuntu11) ...
Setting up apport (2.0.1-0ubuntu11) ...
apport start/running
Setting up apport-gtk (2.0.1-0ubuntu11) ...
Setting up firefox (14.0.1+build1-0ubuntu0.12.04.1) ...
Please restart all running instances of firefox, or you will experience problems.
Setting up firefox-globalmenu (14.0.1+build1-0ubuntu0.12.04.1) ...
Setting up firefox-gnome-support (14.0.1+build1-0ubuntu0.12.04.1) ...
Setting up firefox-locale-en (14.0.1+build1-0ubuntu0.12.04.1) ...
Setting up firefox-locale-zh-hans (14.0.1+build1-0ubuntu0.12.04.1) ...
Setting up gstreamer0.10-alsa (0.10.36-1ubuntu0.1) ...
Setting up gstreamer0.10-gnomevfs (0.10.36-1ubuntu0.1) ...
Setting up gstreamer0.10-plugins-base (0.10.36-1ubuntu0.1) ...
Setting up gstreamer0.10-plugins-base-apps (0.10.36-1ubuntu0.1) ...
Setting up gstreamer0.10-x (0.10.36-1ubuntu0.1) ...
Setting up thunderbird (14.0+build1-0ubuntu0.12.04.1) ...
Installing new version of config file /etc/apport/blacklist.d/thunderbird ...
Setting up thunderbird-globalmenu (14.0+build1-0ubuntu0.12.04.1) ...
Setting up thunderbird-locale-en (1:14.0+build1-0ubuntu0.12.04.1) ...
Setting up thunderbird-locale-en-us (1:14.0+build1-0ubuntu0.12.04.1) ...
Setting up xul-ext-ubufox (2.1.1-0ubuntu0.12.04.1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
 oracle-java7-installer
Error in function: 
Setting up oracle-java7-installer (7u3-0~eugenesan~precise4) ...
Downloading...
--2012-07-18 11:03:58--  http://download.oracle.com/otn-pub/java/jdk/7u3-b04/jdk-7u3-linux-i586.tar.gz
Resolving download.oracle.com (download.oracle.com)... 63.97.123.18
Connecting to download.oracle.com (download.oracle.com)|63.97.123.18|:80... connected.
HTTP request sent, awaiting response... 302 Moved Temporarily
Location: https://edelivery.oracle.com/otn-pub/java/jdk/7u3-b04/jdk-7u3-linux-i586.tar.gz [following]
--2012-07-18 11:03:59--  https://edelivery.oracle.com/otn-pub/java/jdk/7u3-b04/jdk-7u3-linux-i586.tar.gz
Resolving edelivery.oracle.com (edelivery.oracle.com)... 23.13.178.174
Connecting to edelivery.oracle.com (edelivery.oracle.com)|23.13.178.174|:443... connected.
HTTP request sent, awaiting response... 302 Moved Temporarily
Location: http://download.oracle.com/errors/download-fail-1505220.html [following]
--2012-07-18 11:03:59--  http://download.oracle.com/errors/download-fail-1505220.html
Connecting to download.oracle.com (download.oracle.com)|63.97.123.18|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 5307 (5.2K) [text/html]
Saving to: `./jdk-7u3-linux-i586.tar.gz'

     0K .....                                                 100%%  462K=0.01s

2012-07-18 11:03:59 (462 KB/s) - `./jdk-7u3-linux-i586.tar.gz' saved [5307/5307]

Download done.
sha256sum mismatch jdk-7u3-linux-i586.tar.gz
Oracle JDK 7 is NOT installed.
dpkg: error processing oracle-java7-installer (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 oracle-java7-installer
share|improve this question
    
On the popup that says "Package Operation Failed," we need to see the contents of the "Details" drop-down. –  Tom Jul 17 '12 at 14:37
    
from your second image , click the Details in package operation failed ,and copy-paste the error here. –  atenz Jul 17 '12 at 14:47
    
@tijybba Okay, did it for an update. (I would have tried it for the image, but for some reason, I didn't think clicking details on the image would of worked. :D) –  PyRulez Jul 18 '12 at 15:09
    
sha256sum mismatch jdk-7u3-linux-i586.tar.gz is corrupted package , do it manually by following this guides , guide2. But your initial problem seems to be SOLVED through refreshing Updating manager , JDK is new problem. Refer the linked guides for installing them. –  atenz Jul 18 '12 at 15:20
    
Consider this Excellent Answer by SirCharlo , for your JDK error. To Mods ,Possible duplicate too. –  atenz Jul 18 '12 at 16:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.