Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had set my PC like this:

/boot - 250 MB ext3  
/ 100 GB ext4, Kubuntu

Now I needed to install Ubuntu so I made a new 8 GB partition as / and formatted the previous /boot partition and set that same partition as new /boot for this new installation.

The thing is that now my Kubuntu partition is like just a /home partition and a few other system folders but without a /boot and grub sees only the new Ubuntu installation.

Please help, all my work for 1.5 years is on Kubuntu and I have to get it back. I could go and copy my firefox profile(cause this is the most important that I have there) but I would really prefer to have my system back.

Edit:
When I do sudo update-grub it says this:

Generating grub.cfg ... 
Found linux image: /boot/vmlinuz-3.2.0-26-generic 
Found initrd image: /boot/initrd.img-3.2.0-26-generic 
Found linux image: /boot/vmlinuz-3.2.0-23-generic 
Found initrd image: /boot/initrd.img-3.2.0-23-generic 
Found memtest86+ image: /memtest86+.bin 
Found Ubuntu 12.04 LTS (12.04) on /dev/sda6 
done 

My Kubuntu is on /dev/sda6
But when I restart it shows only this options:

Ubuntu, with Linux 3.2.0-26-generic 
Ubuntu, with Linux 3.2.0-26-generic (recovery mode) 
Previous Linux versions(in here are 3.2.0-23 and 3.2.0-23 recovery mode) 
Memory test (memtest86+) 
Memory test (memtest86+, serial console 115200) 

And that's it, no Kubuntu or Ubuntu 12.04 LTS on /dev/sda6.
In a post someone said that grub.cfg has to be updated manually(to write the entry for Kubuntu in my case) but it didn't work, may be I did something wrong...

Edit2:
I added manually Kubuntu in grub.cfg, copied the Ubuntu menuentry and with the help of sudo blkid found out the UUID and replaced the Ubuntu partition UUID with the Kubuntu partition UUID. Restarted, it was there, booted but now it shows that: enter image description here

If I press S it continues and boots up all good...
Anyone knows how to get rid of the notice? :)

share|improve this question
    
what is your kubuntu version and ubuntu version? ; you have deleted your kubuntu kernel and initrd files. But you "may" able to boot your kubuntu system with ubuntu kernel and initrd. –  Manula Waidyanatha Jul 17 '12 at 12:07
    
@ManulaWaidyanatha Kubuntu 12.04 LTS and Ubuntu 12.04 LTS –  Lilian A. Moraru Jul 17 '12 at 14:54
    
@LilianA.Moraru Special Extra thanks for small sized image –  Anwar Shah Jul 18 '12 at 3:59
add comment

1 Answer

up vote 1 down vote accepted

Answer of the Question before edit below:

After Latest Edit of the question, It seems OP has successfully booted to Kubuntu and My assumption (that he deleted the kernels also with boot partition) was wrong. Then the question becomes more or less like this

I have finally booted to Kubuntu, but How can I avoid that screen in booting telling to press S for skip mounting?

The answer to this question is :

  • Open /etc/fstab file of Kubuntu partition with root privilege.
  • Delete the line like this

     UUID=xxxxxx        ext4        /boot       0   0  
    

    that is delete the line containing /boot, that was previously used for mounting boot partition when you have one before, but not now.

Then all will be OK.


First answer Before Edit, Assuming He has already deleted kernels of Kubuntu with boot partition.

Depending of Your installed Kubuntu version, Use the following procedure.

  1. If you don't have the Kubuntu iso (same version as the installed one), get one.

  2. Make two folders (in the folder where your kubuntu iso resides) with name iso and live.

  3. Open a terminal and go to the directory of iso file of Kubuntu. For example, we assume, you have that iso in your Downloads folder in your home directory. And let, the name of the iso be kubuntu.iso for simplicity.

  4. mount the iso in iso folder by this command

     sudo mount ./kubuntu.iso ./iso
    
  5. Then mount the filesystem.squashfs file in the casper directory of mounted iso file into the live folder.

    sudo mount ./iso/casper/filesystem.squashfs ./live
    
  6. Then copy the vmlinuz and initrd.lz in the kubuntu partition. First create a boot folder in it. Then copy the required files in that folder.

    1. First mount the partition of old Kubuntu. you need to know, /dev/sdax number of that partition. Use sudo blkid command to see that. We assume, it is /dev/sda2. Mount it with the command below in the /mnt folder.

      sudo mount /dev/sda2 /mnt
      
    2. When it get mounted, create a folder boot in that partition.

      sudo mkdir /mnt/boot
      
    3. Then use the command to copy vmliuz and initrd.lz file in the /boot folder of the mounted kubuntu partition

      sudo cp ./iso/vmlinuz /mnt/boot  
      sudo cp ./iso/initrd.lz /mnt/boot
      
    4. Then use the command to copy the content of boot folder in the iso file to the newly created boot folder of the kubuntu drive.

      sudo cp -r ./live/boot/* /mnt/boot 
      
  7. Then unmount the ./iso and ./live folder (This step is optional)

     sudo umount ./live
     sudo umount ./iso
    
  8. Then run the command to let grub to detect your kubuntu

     sudo update-grub
    

Hope this will help.

Reference: I accidentally deleted my boot folder and use that procedure to be able to boot to that disto again.

share|improve this answer
    
There was no need to mount and copy, I already had /boot on /dev/sda6(where my Kubuntu partition is), I don't know why... Read the Edit I made for the initial post, may be you have some idea... I will try to write manually in grub.cfg the entry to Kubuntu. –  Lilian A. Moraru Jul 17 '12 at 16:42
    
It worked adding manually. I copied from grub.cfg the Ubuntu menuentry and just replaced the UUID of Kubuntu partition instead of the Ubuntu partition UUID. There is a little problem yet... –  Lilian A. Moraru Jul 17 '12 at 17:19
    
@LilianA.Moraru Have you successfully boot to the Kubuntu then. After pressing S? –  Anwar Shah Jul 18 '12 at 3:47
    
Thank you, it worked! –  Lilian A. Moraru Jul 18 '12 at 13:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.