Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just installed Ubuntu 12.04 and updated all the packages. If I connect a USB stick to the PC it is not mounted automatically, if I run, say, mount -t vfat /dev/sdc1 /media/usb_stick I get Permission denied result. So the command returns a successful result only under sudo. I'm the only user of the PC. What's is wrong? With former versions of Ubuntu it was fine.

share|improve this question

2 Answers 2

What are the permissions on the mount point? If you run ls -l /media What permissions do you see on the directory?

share|improve this answer
    
vkirsan@sea:0:~> ls -l /media total 12 drwxr-xr-x 2 root root 4096 Jul 17 18:13 ash/ drwxr-xr-x 2 root root 4096 Jul 27 19:25 clay/ drwxr-xr-x 2 root root 4096 Jul 14 01:29 glint/ vkirsan@sea:0:~> –  krokoziabla Sep 2 '12 at 18:47
    
I have deleted those subfolders, hoping that they will be automatically created when I insert a stick (as on other machine with no such a problem). But still result is the same. Could it be that I have such a restriction due to the domain policy? I'm using LikeWise Open to be in an AD domain. –  krokoziabla Sep 3 '12 at 11:41

If your USB stick is formatted ntfs make sure you have the NTFS Fuse programs installed.

sudo apt-get update && sudo apt-get upgrade && sudo apt-get install ntfs-3g ntfsprogs;

ntfs support seems to have been removed since 12.04LTS

share|improve this answer
    
Thank you. I tried USB sticks only of FAT and ext4 file systems. –  krokoziabla Jan 14 '13 at 13:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.