Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

there is no problem in my main user account, but in other is system font very ugly. Ragged and thin. I use default ubuntu - font - family. The same situation is in LightDM.

I tried delete .fontconfig folder, unity --reset, Ubuntu Tweak and nothing helped.

Thanks P.

Screenshot of broken font: http://i.minus.com/ibnxpjNSousCBJ.png

Scrennshot of normal font: http://i.minus.com/iQzXY2eMAiTcY.png

share|improve this question
add comment

3 Answers

Check Universal access settings. You should keep Text size in normal size.

enter image description here

share|improve this answer
    
Thanks for answer. Yes, I have Normal text size. But i have uninstalled access applications. –  user77499 Jul 17 '12 at 8:41
    
can please provide any screenshoot of your desktop? –  shantanu Jul 17 '12 at 8:50
add comment

Fonts must be installed in /usr/share/fonts (create a subdirectory in the directory to store the .ttf files) to be accessible by all users.

Then rebuild font cache with:

fc-cache -fv
share|improve this answer
    
Hi, thanks. I have in /usr/share/fonts/ directory truetype. In this directory create subdirectory? Truetype dir is accesible for all users. –  user77499 Jul 17 '12 at 8:44
    
That's correct, store each group of .ttf in a folder named as font family name in truetype directory. –  jasmines Jul 17 '12 at 8:56
    
Extract all subdirectories in new one? –  user77499 Jul 17 '12 at 9:11
    
No, simply add the missing ones! –  jasmines Jul 17 '12 at 9:13
    
I think, that I haven't problem with new font. I use Ubuntu-font-family a this subdirectory is in truetype dir. Of course, accesible for all users (access to files) –  user77499 Jul 17 '12 at 9:18
show 7 more comments

Might have something to do with font smoothing or hinting and default font selection.

  • Install Ubuntu Tweak:

    sudo apt-add-repository ppa:tualatrix/ppa
    sudo apt-get update
    sudo apt-get install ubuntu-tweak
    

And check, in the fonts section in 'Tweaks' or another section, that all the fonts (apart from one which should be set as Sans) are set to Ubuntu, and make sure font smoothing and hinting (Basic) are enabled.

share|improve this answer
    
Hi, Marcappuccino, thanks for answer. I have Ubuntu Tweak too and the font settings is same as in Myunity. I thing, that settings is, how should be. –  user77499 Jul 17 '12 at 16:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.