Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since a few weeks (after a distribution upgrade), about every program with a graphical user interfaces crashes at some point with the same error:

GLib-GIO-ERROR **: Settings schema 'org.gtk.Settings.FileChooser' does not contain a key named 'last-folder-uri'

It happens about every time a file open dialog shows up, but also when the network manager asks for a WiFi password. (Which means I can't open files in any gtk application and only connect to open wireless networks.)

/usr/share/glib-2.0/schemas/org.gtk.Settings.FileChooser.gschema.xml does contain <key name='last-folder-uri'... etc. Running glib-compile-schemas doesn't seem to help.

Any ideas?

Edit:

It's not just for one user. If I log in as a guest ('Guest Session'), the same happens.

Edit 2:

$ dpkg -s libgtk-3-common | grep Version
Version: 3.4.2-0ubuntu0.3

Contents of /usr/share/glib-2.0/schemas/org.gtk.Settings.FileChooser.gschema.xml: https://gist.github.com/f90a230bf6077cbaa967

share|improve this question

1 Answer 1

Try to add it manually:

 dconf write "/org/gtk/settings/file-chooser/last-folder-uri" "'file:///home/'"

Moreover, make sure that gsettings-data-convert is in your startup applications.

share|improve this answer
    
When trying to set it manually, it says: Schema 'org.gtk.Settings.FileChooser' is relocatable (path must be specified) –  Maurice Jul 17 '12 at 10:23
    
Ok, I've edited. Try now! –  jasmines Jul 17 '12 at 10:39
    
It doesn't seem to work. dconf write ... goes fine; the value does now appear in dconf-editor. (Before, /opt/gtk/ didn't even contain settings.) But all programs still give the same error about not finding the last-folder-uri key. –  Maurice Jul 17 '12 at 10:51
    
After gsettings-data-convert? –  jasmines Jul 17 '12 at 11:14
    
Yes, tried that already. Didn't help. Dconf and Gsettings save their setting per user, right? (Because if i log in as a guest (guest session), I get the same errors, which i think is strange.) –  Maurice Jul 17 '12 at 11:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.