Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been googling everywhere I could think of for the past three days now and I finally just made an account here to ask my question. I'm a total Ubuntu n00b, I'm converting from Windows (which I know pretty much inside and out).

I tried to install the fglrx Proprietary Catalyst 12.6 drivers on my system (Ubuntu 12.04 LTS 32 bit) but every time I do I eventually end up with an unfixable boot error and have to reinstall Ubuntu. I've reinstalled 3 times already. The reason I want the drivers is because I have two monitors, and they only work in mirrored mode without the proprietary drivers for me.

I got them to work once without, but my larger monitor only ran in 1024x768. Is there some way to install the drivers that will make them not be so finicky? I heard there were also open source drivers as well? How do you install those?

Thanks.

share|improve this question
    
I've experienced similar issues trying to install the Catalyst 12.6 driver, and have had to roll-back. How are you installing the driver? I'm currently running Ubuntu 12.04 (64-bit) with Catalyst 12.4 and that works fine with dual screens. –  Jagged Jul 17 '12 at 1:55

4 Answers 4

I have a 5450 driver, which works well with two monitors using either the standard open drivers or the proprietary drivers - even off the liveCD.

What happens when you try to uncheck the "Mirror Displays" checkbox with the standard driver? Make sure both monitors are switched on using the sliding switch under the displays in the middle, and the resolution is set correctly for both monitors.

I've never had to reinstall Ubuntu for many different versions. One trick I found once when my system wouldn't boot normally was to replace the file xorg.conf with a plain vanilla version. The full version to this file is:

/etc/X11/xorg.conf

It is a plain text file, and can be edited or replaced either from a virtual terminal, if that is working, or even using a live CD to access the partition. The one for the plain, open-source driver that comes standard is very simple:

Section "Screen"
        Identifier      "Default Screen"
        DefaultDepth    24
EndSection

Section "Module"
        Load    "glx"
EndSection

If you find this same file on your system, you can copy it to something like xorg.conf.backup in case of future problems.

Let me know if you have questions. I used to be like you, a windows expert from version 1, but now I dread having to configure Windows because it's actually harder; I never used to believe people who said that either, but after a certain point (for me, a couple of years), you realize it's true.

share|improve this answer
    
Okay, it's working for dual screen. But the max resolution is 1024x768 for both of them. And one of them should support higher resolution. –  3DModelerMan Jul 17 '12 at 21:36
    
Do you have the proprietary driver active? If so, you need to set things in the AMD catalyst app. With the default open-source driver, you use Displays settings, where you click on one or the other display icon, and set the resolution underneath. I'm not really sure how to force a different resolution, as mine always seemed to have the correct one already. Maybe someone else will know, or I'll look in to it and check back. –  Marty Fried Jul 18 '12 at 3:05
    
You might find some help in this article, especially toward the end of the article. –  Marty Fried Jul 18 '12 at 16:56
    
Thanks. I'll read through it and try to figure out how it works. I'll post back with my results. –  3DModelerMan Jul 19 '12 at 0:17

Just connect your system in Ubuntu with Internet and open "Additional Drivers" application. Then it shows available graphics drivers for your system. From there you can install them and there is no problem with this.

share|improve this answer
    
Additional drivers, as of 12.10, is now located under 'Software Sources' in the software center. See this answer for more information. –  Seth Dec 4 '12 at 0:44

I am a user of a very similar card, with a fully functioning Ubuntu set up with Catalyst aka fglrx.

You want Catalyst 12.9 out of the repositories i.e. what Ubuntu suggests in the Software Sources part of the Software Center. Don't go for earlier versions and don't go for more recent versions. You will also want to install linux-headers-generic.

If you look here, you should see a more long winded version in an answer to another question. That is how I did it - after numerous failed attempts - although there may be superfluous steps.

share|improve this answer
    
Please copy/paste the link to your other/more complete answer onto this one. –  ImaginaryRobots Nov 20 '12 at 20:24

I would strongly suggest you make sure that you have followed the advice in the askubuntu community wiki for this which is here:

Ask Ubuntu ATI Community Wiki

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.