Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I aliased google-chrome and whitelisted myself in sudoers so now when I type sudo chrome it runs sudo -u chromeuser -i google-chrome &. (For reasons outlined below) Since all other users besides myself have a home directory on ext3 this works very well. The only downside is that chrome, when started as chromeuser, will not play sound.

edit: Moved question to top for clarity

Background for anyone who's interested:

I set the home directoy for one of my users to be on an NTFS partiton so that it is accessible from Windows. I'm the only one who uses the computer so I set fuse to allow 777 permissions to that partition. I deleted /home/me and created a symlink in it's place that points to the NTFS partition (which is mounted at /Shared/home).

Chrome doesn't play well with that configuration because it creates various caches under your home directory and NTFS performance couldn't keep up with it. I fiddled with a few options to chrome (--user-data-dir --disk-cache-dir) but I couldn't get 100% of chrome's open files under my control. So my solution was just run chrome as it's own user.

tldr; I started a program as another user, doesn't seem to want to play sound. Is this related to alsa?

share|improve this question
    
Is this still an issue? –  guntbert Jul 18 '13 at 21:58
    
It wasn't a sustainable setup, the fault was with Chrome's inability to respect --user-data-dir and --disk-cache-dir. If those had worked there would be no need for a second user. It may have been fixed by now, I'm unsure as I stopped doing this long ago. –  Huckle Jul 19 '13 at 16:31
    
How about you delete it? –  guntbert Jul 19 '13 at 19:45
    
Might still be useful to someone having trouble with chrome. –  Huckle Jul 22 '13 at 16:30

1 Answer 1

Answered in question by OP

The solution was just run chrome as it's own user.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.