Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just got my new asus laptop from the store and wanted to use Ubuntu. But after I installed all updates and stuff, the launcher icons went invisible. They still works and text is displaying when I hover them. All the icons are invisible. I've tried to reinstall unity (http://askubuntu.com/questions/131016/how-can-i-remove-and-re-install-unity) but that does not work. I've also tried to use those commands with no progress:

unity --reset-icons
unity --reset

After a reboot, the launcher is still not rendering the icons properly.

The only thing to get it work is to login with Ubuntu2 at the login screen, but I've noticed that by doing this, the computer does not use the GPU, and the graphic drivers are not running.

Does this means that I need new graphic drivers or something? Because this only happens in fallback mode.

Any ideas?

I'm using kernel 3.5.0-4 and the automatic installed drivers from "additional drivers" program.

share|improve this question

2 Answers 2

Did you install the xorg-edgers ppa?

From the PPA: July 13th: Mesa currently has problems with unity where the launcher icons are invisible, it's suggested to hold mesa back to the 0529 version, stop using this PPA, or use another session such as gnome or unity-2d until it is fixed.

I haven't tried it myself yet, but that could be the problem.

share|improve this answer

If you are running it on the xorg-edgers ppa, you can downgrade Mesa libraries.

sudo apt-get install libgl1-mesa-dri=8.0.2-0ubuntu3 mesa-common-dev=8.0.2-0ubuntu3
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.