Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I try to istall Ubuntu 12.04 on my Lenovo U310 laptop. The problem is here: GParted see my HDD, all is okay. But when I launch installation - there is no partitions to choice.

I think it happens, cause U310 has 2 HDDs (normal and SSD) and may be boot process contains some magic inside...

Can anybody help with it?

Thanks.

Update 1

After some experiments I found, that problem is in intel Rapid Start Technology (iRST). It uses SSD drive as cached disk, and HDD as accelerated. And both of them work in RAID0. That's why Ubuntu installer can't see table partition.

So, to fix it, I disabled (Ctrl+I during loading notebook) acceleration of the 500 Gb hard drive and all is fine.

I'm sorry if it copybook maxims, but maybe it helps to someone.

Love Ubuntu :)

share|improve this question
1  
Is AHCI enabled in the BIOS? –  Mitch Jul 16 '12 at 20:24
    
No, for now. But I have already tried this mode. And also tried another 'Compatible' mode and no results :( –  Psylone Jul 16 '12 at 20:31
    
May be the most easiest way - to completely remove Windows 7, but I want try to save it if possible. –  Psylone Jul 16 '12 at 20:33
add comment

1 Answer 1

up vote 3 down vote accepted

Partition tables are unreadable, they need to be GPT format. I was not able save the OEM install.

This voids your warranty!!

There is bios bug with Intel Rapid start and Lenovo u310. Disable it in the bios before continuing. If you erase OEM partitions while bios is in Rapid Start mode, you lose a ability to enter bios setup, probably forever. It was documented in u300 manual that you could enter the bios while in rapid start mode by using the "One key restore button", but it is conveniently missing from the u310 manual so it's not considered a defect, and it definitely doesnt work. Boooooo...!!

  1. Do clean shutdown for OEM windows and change disk controller to AHCI mode, and change boot order as needed. (raid mode may work, I didn't try it, you may be able to dual boot in raid mode)
  2. Boot into live cd Ubuntu (be sure F2 option pops up on post, if not, you're in rapid start mode)
  3. Search for "disk" in unity
  4. Launch disk manager
  5. Rewrite partitions as needed and install Ubuntu.

Known issues: trackpad unsupported, right click button doesn't work. Google it, there a fix that removes trackpad options like scrolling and tap click.

Cairo dock OpenGL mode buggy as heck. No fix that I can find.

Beware rapid start bios issue. Research it, disable it. You have been warned.

share|improve this answer
    
Thank You, Jeremy, for this information! Probably, modern times require difficult decisions... –  Psylone Jul 18 '12 at 5:43
    
I disabled the iRST and Changed the RAID to AHCI Mode and now I can see my partitions on the Install Dialog!! Lets c how far it goes...(although I am trying to Install Windows 8 RP...;-)! ) –  user91370 Sep 18 '12 at 22:06
    
. Boooooo...!! Indeed, f**k lenovo, please buy companies who support and sell devices preinstalled with linux! –  Oz123 Sep 10 '13 at 15:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.