Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Unity doesn't load, no Launcher, no Dash appears

I recently tried to update my desktop to 12.04- I was actually still using 9.10, so I've gone through the update process several times already, and this was the last one. I restarted, and it went to the log-in screen just fine, but when I log in, all I get is a the background image. There are no bars, no dock- I can right-click and do some settings menu stuff, but that is all. How can I fix, if possible?

share|improve this question
    
Try to login in Unity 2D. Is it login ok? If so then you have to search for video drivers. –  arhimed Jul 16 '12 at 19:31
    
Maybe this topic is of any help to you: ubuntuforums.org/showthread.php?t=1606459 It contains information on how to start it from a command line interface, or when you're stuck. EDIT: This was linked to this issue: askubuntu.com/questions/17381/… Might be worth checking that out, too. –  Rick Kerkhof Jul 16 '12 at 20:07
    
The problem is I can't use the terminal either- I get it open but can't type on it. I also can't seem to log in through CTR ALT F1. Everything does work in Ubuntu 2d, though. Sorry for the duplicate question, I swear, I tried to check –  user77415 Jul 16 '12 at 23:33
    
You can select the recovery mode kernel in the boot menu (grub2) and drop to root shell. There you could try to fix your problem. Maybe purge and reinstall Unity? –  con-f-use Aug 20 '12 at 11:23
add comment

marked as duplicate by jokerdino, ajmitch, con-f-use, Jorge Castro, hbdgaf Aug 22 '12 at 1:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

As mentioned by Fossfreedom,
your question is similar to this one. And its answer may be the answer you are expecting.

To confirm that the reason of the problem is the Unity installation,
before trying the solution of the similar question, you can try opening your session without Unity => with a GNOME Classic (no effect):

  • either when you chose your session
    enter image description here

  • or if you are using an auto login:

    • ControlAltF1
    • login with your super user login
    • edit file /etc/lightdm/lightdm.conf (I personally edit using vi)
      and define greeter-session=gnome-fallback
    • sudo reboot
share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.