Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Okay, well, I'm mildly surprised I don't see this question asked yet, as PP as I like to call it (12.04) boasted support for two monitors.

Why can I not use two monitors? My current set-up is kinda sketchy, so that's probably why. But what part of it is screwed up? Alright. I have an GeForce NVidia 9800 that has two output slots, and I have them hooked up to two computer screens of different resolution. I have it working perfectly in Windows. It also works well in the Ubuntu sign-in screen. However, the problem here lies whenever I sign into my user. I sign in like normal, but the second screen shuts off. When I go to "Displays", it recognizes the screen for me and lets me configure it just like in Windows. HOWEVER, whenever I click apply, it crashes my system and I must restart and it comes back without the new settings.

Yes, I'm using the correct resolutions and I'm not mirroring. I believe I'm also up-to-date on my drivers.

What is wrong here? Is this a known problem I'm unaware of?

share|improve this question

closed as too localized by RobotHumans, Bruno Pereira Jul 16 '12 at 20:19

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

you are using the "Monitor" option under the gear on the top right corner of your desktop? – user827992 Jul 16 '12 at 19:09
Well, I used the Dash thing, but yeah, that's the same tool. – tacozmeister Jul 16 '12 at 19:09
using the control panel that comes with your drivers is always a better idea, also you probably have to specify what kind of connections you use to connect your monitors. – user827992 Jul 16 '12 at 19:15
.. I would if I knew what they were xD ;] Whatever it is, it's likely not the connection because it works on Windows. – tacozmeister Jul 16 '12 at 19:16
HAHAHA, okay, you guys wanna hear something funny? I reinstalled my drivers, now it will only recognize my smaller screen and it designates it "laptop." What?? – tacozmeister Jul 16 '12 at 19:22
up vote 0 down vote accepted

Okay, I figured it out myself. I had to reinstall my drivers and use the "NVidia X Server Settings" and it took me a while to set up, but it works :D

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.