Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have uninstalled fglrx modules and ati modules in order to re-install them.after the rebooting the i cant come up with GUI.... On startx it displays

Failed to load module fglrx (module does not exist 0) No drivers available ddxsiggiveup :closing log giving up xinit: No such file or directory (errno 2).unable to connect to Xserver xinit : No such process(errno 3): Server Error

share|improve this question

closed as off topic by Jorge Castro, Bruno Pereira Jul 16 '12 at 18:53

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
For distributions other than Ubuntu, try our friends at unix.stackexchange.com –  Jorge Castro Jul 16 '12 at 16:18
    
Indeed, I hope you find a good answer, but BackTrack is not supported here, so we'll probably close this question. There are many places where you can get community support for BackTrack, including BackTrack forums and (as Jorge Castro suggested) Unix.SE. –  Eliah Kagan Jul 16 '12 at 18:53

2 Answers 2

Try:

sudo apt-get install fglrx fglrx-amdcccle

If that doesn't work:

sudo apt-get purge xorg-driver-fglrx fglrx*
sudo apt-get install fglrx fglrx-amdcccle

If that doesn't work then there's definetley something wrong with the driver or possibly your hardware (not likeley).

sudo apt-get purge xorg-driver-fglrx fglrx*
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri fglrx-modaliases
sudo dpkg-reconfigure xserver-xorg

...And (you will probrably need this in the future and it told system settings what driver I was using) install mesa-utils.

sudo apt-get install mesa-utils    
share|improve this answer

Delete /etc/X11/xorg.conf and try again.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.