Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to run virt-manager from the server itself (so that I can use the interface management feature which is not available over ssh connection).

However, I plan to launch virt-manager over an ssh connection forwarding X11 to my laptop where I run a full Ubuntu 12.04 desktop setup.

When I run "apt-get install virt-manager" on the ubuntu 12.04 server it of course wants to add X11 server, gnome libraries, etc... but I don´t want any of those on my server.

Is there a way to tell apt never to install graphical environment related packages because I will always forward X11 to a remote client?

share|improve this question
I think that, to use X11 forwarding, you still need a local X11 ... (you dont need gnome, though ...) – josinalvo Jul 16 '12 at 14:22

apt-get --nodeps install PACKAGENAME


In order to use ForwardX11 yes in your /etc/ssh/sshd_config, you must have X11 installed on both the remote and local machine.

Just like you must have an ssh client and an ssh daemon/server, you must have an X11 client and X11 server.

I hope that this helps clarify things.

share|improve this answer
sorry, but it is a really really bad idea to install software with --nodeps option. You may run into big problems, especially when you want to upgrade ubuntu at a later time. – gemue2010 Jul 16 '12 at 21:07
No reason to apologize. You are making a very valid statement. – earthmeLon Jul 17 '12 at 20:32

If you're installing an application which uses certain libraries, then those libraries must be installed for the application to run. It doesn't matter if you're going to run the application remotely or not.

While most of the Xorg server packages probably aren't needed, and you can remove them, you will also likely need to have at least one installed. Also, just because it is installed, doesn't mean you have to run an X session/server on your server system.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.