Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to compile the Linux From Scratch kernel, version 7.1 on Ubuntu 12.04, running inside of a virtualbox.

I've worked through a part of the tutorial successfully, but when I reach Step 5.7: Building Glibc-2.14.1, I get an error when I make.

In file included from ../sysdeps/unix/sysv/linux/syslog.c:10:0
../misc/syslog.c: In function '__vsyslog_chk':
../misc/syslog.c:144:9: warning: variable 'prioff' set but not used [-Wunused-but-
    set-variable
../misc/syslog.c:123:1: sorry, unimplemented: inlining failed in call to 'syslog':        
    function body not available.
../misc/syslog.c:155:9: sorry, unimplemented: called from here
make[2]: *** [/mnt/lfs/sources/glibc-build/misc/syslog.o] Error 1
make[2]: Leaving directory `/mnt/lfs/sources/glibc-2.14.1/misc'
make[1]: *** [misc/subdir_lib] Error 2
make[1]: Leaving directory `/mnt/lfs/sources/glibc-2.14.1'
make: ***[all] Error 2

After some googling, I saw a filed bug report: http://sourceware.org/bugzilla/show_bug.cgi?id=10375 that had the same errors I was seeing, but I couldn't divine a solution.

Any tips on where I should head?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

The bug report is pretty obvious -- see the last two posts, especially.

The problem is that (their) GLIBC is incompatible with the FORTIFY_SOURCE option set by default by Ubuntu's gcc.

The better solution is to get the latest copy from trunk, where the problem has been fixed; alternately, unset (disable) that option in the makefile or before calling make with:

export CFLAGS=-U_FORTIFY_SOURCE
share|improve this answer
    
I appreciate you clearing up for me how to unset flags while using make. My problem seemed to be just pebkac, though. Starting the tutorial again from the top (only 4 or 5 steps) managed to get me through this problem. –  Eagle Jul 17 '12 at 14:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.