Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Well, I was amongst the 12.04 Beta upgraders, and since then I've lost the ability to write in Arabic, and I've been using Ubuntu since 2008 as an only OS without any issues, and been upgrading since then as well, except on this machine, which received one upgrade from 11.10 to 12.04 and it got messed up.

I've added Arabic like usual, but it doesn't change with the keyboard's short-cut, and when I do it manually with the Mouse, then it just doesn't work, and it keeps writing in English instead.

I've tried to install some iBus things, and added Arabic-kbd (m17n) but it still remains messy, let alone not having the same layout, and all I want is to get to NORMAL.

So, please, is there any way to reset or initialize these keyboard related settings, so I can get back to normal and stop using the Mac just to type in Arabic, or so often using XP over Vbox?

And please, no Re-install option! I just can't backup all my work right now, and there are a lot of tasks waiting for me to get them done.

Thanks for any kind of support :)

share|improve this question
    
Fixed anyway :) –  Aboubakr Jul 19 '12 at 17:34
add comment

1 Answer

I got the answer from Alaswadi Khd. It is very helpful and straightforward·

  1. System Setting → Keyboard Layout → then you can add the using + any language.
  2. Click on Arabic → Option → Keys to change Layout → Select Alt+xxx.

You're done.

With Alt+xxx you will be able to shift the direction.

With Ctrl+Alt you will able to shift the language.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.