Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using stackapplet v1.4 it's not getting started automatically.Every time i want to start it manually from Application>>Accessories>>StackApplet.I am sure i have enabled the option Start StackApplet during login but it's not working.What's going wrong here?

~/.xsession-errors shows the following result. alt text

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Open up ~/.config/autostart/stackapplet.desktop, verify that it is the same as this:

[Desktop Entry]
Type=Application
Exec=python /usr/share/stackapplet/stackapplet.py
Icon=/usr/share/pixmaps/stackapplet.png
Terminal=false
Comment=a panel indicator for monitoring StackExchange sites
Name=StackApplet
Categories=Utility;

The problem is likely with the Exec line, if you used to be using an older version that had a different Exec command.

Even if they are the same, try removing that file. Then un-check and re-check the Start Stackapplet during login checkbox.

UPDATE: Looking at your ~/.xsession-errors, StackApplet needs internet access to work. If you aren't connected to the internet right away on login, you'll need to delay StackApplet from starting before you have connected to the internet.
Paste the following in a file called .stackapplet-start.sh in your home folder:

#!/bin/bash
sleep 30 && python /usr/share/stackapplet/stackapplet.py

Make that file executable:

chmod a+x ~/.stackapplet-start.sh

Now open System -> Preferences -> Startup Applications, edit the StackApplet entry and change the Command: to /home/<USERNAME>/.stackapplet-start.sh.

share|improve this answer
    
Yep it has the same line. –  karthick87 Dec 6 '10 at 16:57
    
@karthick87 Open up ~/.xsession-errors and search for anything related to stackapplet.desktop –  Alvin Row Dec 6 '10 at 17:16
1  
Eventually this won't be an issue - the app will still start up without Internet access. But that hasn't been fixed yet :) –  Nathan Osman Dec 17 '10 at 4:38
    
This is now fixed. The application should start regardless. –  Nathan Osman Nov 16 '11 at 5:12
add comment

verify that it appears in the startup application: System > Preferences > Startup Applications.

If it is not there , create a launcher, and add it.

-- Yonatan

share|improve this answer
    
Yes it's there in startup list –  karthick87 Dec 6 '10 at 12:12
    
what's the entries command? –  Stefano Palazzo Dec 6 '10 at 12:24
    
python /usr/share/stackapplet/stackapplet.py –  karthick87 Dec 6 '10 at 19:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.