Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have both Ubuntu and Lubuntu installed on the same machine, on different partitions. They are both used for different things, and I like to hibernate my main Ubuntu installation to my single swap partition when I switch between them. However, they are both recognizing the same swap partition, and when I boot into Lubuntu after hibernating my Ubuntu installation, it tries to load from swap and all HELL breaks loose.

So I want to try to make Lubuntu stop recognizing the swap partition. This is a quad core machine, and Swap really isn't needed with LXDE.

share|improve this question
    
You can turn off swap disk by typing this on terminal."sudo swapoff -a" if you ever won't to enable it just type "sudo swapon -a" only turn off your swap if you got ram memory more than 2GB (it's enough for everyday apps with web browsing) –  Prasad RD Jul 16 '12 at 3:24
    
Please remember to accept/upvote the best answer(s) to your question when possible (tick/check mark on the left). This way, the question is marked as "answered" and future readers can refer to it knowing the solution works. Thank you...:) –  izx Aug 26 '12 at 21:25

1 Answer 1

  • Press Alt+F2 and type: gksudo gedit /etc/fstab; enter password when prompted
  • Find a line like the following:

    # swap was on /dev/sda6 during installation
    UUID=adc15cab-1cd4-4278-9a1d-59016cced6dd none      swap  sw    0       0
    
  • Comment out the UUID= line by adding a # in front of it. Save and exit.

  • Lubuntu will no longer attempt to use that swap partition.
share|improve this answer
    
sorry! my browser didn't load your answer in the first attempt. Is there any difference between this method and the simple "Sudo swapoff-a" method? –  Prasad RD Jul 16 '12 at 3:35
1  
@Prasad: swapoff only disables swap, not remove its entry from /etc/fstab. In that case, an accidental swapon, or using other utilities such as gParted, etc. in particular ways may still enable the swap causing problems. –  izx Jul 16 '12 at 3:40
    
Thank you very much, never knew it before! thanks again! –  Prasad RD Jul 16 '12 at 3:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.