Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The subtext here is that i'm trying to see if i can run any gnustep applications in a reasonable way on my ubuntu 12.04 system.

I went to the package list (http://packages.ubuntu.com/precise/allpackages) and sort of chose Cenon at random.

I installed it via sudo apt-get install cenon.app

Then i attempted to run it from the command line by typing Cenon to the command line (bash) prompt.

I immediately got this message in an alert panel saying: You need to install the Cenon Library!

In short, i have duplicated Jorge Castro's experience under ubuntu 11.10. (He reported it in this forum in Cenon will not open or run about 6 months ago.)

I imagine that either the dependencies in the package are not complete, or perhaps the code is misinterpreting some signal it has gotten.

I'd be glad to install some more software to see if that helps (and provides enough information for the package maintainer to fix it).

Thanks in advance for any info!

dan

POSTSCRIPT!

So, i already have egg on my face, i guess.

In fact, the alert panel does come up, but it turns out that i can just close it and proceed.

However, there still seems to be some problem in running the application.

The menus don't show up in the right places, sometimes.

So, for example, if i click to open the files submenu, it may line up with the main menu, but sometimes it doesn't. I also had that experience with another gnustep application i installed this morning, adun.app. (For anybody wishing to try it out, you install it via "sudo apt-get install adun.app" but run it via UL.)

So probably my question should be re-posed to deal with menu/submenu alignment.

share|improve this question

3 Answers 3

up vote 0 down vote accepted

Have you tried installing the package provided by Cenon's developers? Try uninstalling Cenon, then grabbing the appropriate .deb package from the developer's site and installing it from there.

You can install a .deb package by double-clicking it in Nautilus, which should open up Software Center, or through the terminal, via

sudo dpkg -i [name of package]
share|improve this answer
    
compiling from source might also net more useful feedback about any broken / missing dependencies or libraries that the developers want you to have -- but that's a whole new can of worms :) –  OpensourceFool Jul 15 '12 at 21:41

"After installing Cenon (RPM packages) on Ubuntu or Debian I get the following Alert-Box in Cenon: "You need to install the Cenon Library!" Cenon is running and most functions should work already. The only thing that is wrong is the install location, making Cenon search it's files (like device files for import) in a wrong location. Solution: The Debian/Ubuntu location for the Cenon library files is: /usr/lib/GNUstep/Cenon or /usr/local/lib/GNUstep/Cenon However, the RPM location for the Cenon Library files is: /usr/GNUstep/.../Library/Cenon All you have to do, is move the folder 'Cenon' to the correct Ubuntu location, so that it will be found by Cenon. [2010-09-03]"

http://www.cenon.info/frameLoad_gb.html?support_gb.html

share|improve this answer
    
Examining the path is a wise suggestion, @JMX. However, the OP originally installed Cenon using apt-get from a regular repository, meaning it was a .deb (Debian package), not an RPM (Redhat Package Manager (or more recently RPM Package Manager)) file. The OP's follow-up attempt was also from a .deb. –  OpensourceFool Jul 18 '12 at 6:04

Thanks OpensourceFool --- your answer is wise!

Anyhow, for more details, if anybody else is looking , the developer's site you listed actually links back to debian:

http://ftp.debian.org/debian/pool/main/c/cenon.app/

The version that was on their page was 3.91, but that is not on the debian page, however 3.93 is.

So I installed it via

sudo dpkg -i *.deb

and it works now.

Or, at least, the problem with the menus not being properly attached is gone.

There's still the warning at the start though, but for my purpose (of checking for general breakage between Ubuntu and gnustep) it looks like at least there's no gross menu placement problem.

share|improve this answer
    
Great, if the problem is resolved, please mark the question as answered :) –  OpensourceFool Jul 18 '12 at 6:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.