Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Installing packages to end-of-lifed Ubuntu editions?

I am using Ubuntu 8.04 and I want to update it ,but it failed

root@ubuntu:~# apt-get update
Ign cdrom://Ubuntu 8.04.4 _Hardy Heron_ - Release i386 (20100121.1) hardy/main Translation-en_US
Ign cdrom://Ubuntu 8.04.4 _Hardy Heron_ - Release i386 (20100121.1) hardy/restricted Translation-en_US
37% [Connecting to archive.ubuntu.com (91.189.91.25)] [Connecting to security.u^37% [Connecting to archive.ubuntu.com (91.189.91.25)] [Connecting to security.u^37% [Connecting to archive.ubuntu.com (91.189.91.25)] [Connecting to security.ubuntu.com (91.189^Err http://security.ubuntu.com hardy-security Release.gpg                                       
  Could not connect to security.ubuntu.com:80 (91.189.92.166), connection timed out [IP: 91.189.92.166 80]
Err http://security.ubuntu.com hardy-security/main Translation-en_US                            
  Unable to connect to security.ubuntu.com http: [IP: 91.189.92.166 80]
Err http://security.ubuntu.com hardy-security/restricted Translation-en_US                      
  Unable to connect to security.ubuntu.com http: [IP: 91.189.92.166 80]
Err http://archive.ubuntu.com hardy Release.gpg       ^[[15~                            
  Could not connect to archive.ubuntu.com:80 (91.189.91.13), connection timed out [IP: 91.189.91.13 80]
Err http://archive.ubuntu.com hardy/main Translation-en_US
  Unable to connect to archive.ubuntu.com http: [IP: 91.189.91.13 80]
Err http://archive.ubuntu.com hardy/restricted Translation-en_US
  Unable to connect to archive.ubuntu.com http: [IP: 91.189.91.13 80]
Err http://archive.ubuntu.com hardy-updates Release.gpg
  Unable to connect to archive.ubuntu.com http: [IP: 91.189.91.13 80]
Err http://archive.ubuntu.com hardy-updates/main Translation-en_US
  Unable to connect to archive.ubuntu.com http: [IP: 91.189.91.13 80]
Err http://archive.ubuntu.com hardy-updates/restricted Translation-en_US
  Unable to connect to archive.ubuntu.com http: [IP: 91.189.91.13 80]
Reading package lists... Done                        
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/hardy/Release.gpg  Could not connect to archive.ubuntu.com:80 (91.189.91.13), connection timed out [IP: 91.189.91.13 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/hardy/main/i18n/Translation-en_US.bz2  Unable to connect to archive.ubuntu.com http: [IP: 91.189.91.13 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/hardy/restricted/i18n/Translation-en_US.bz2  Unable to connect to archive.ubuntu.com http: [IP: 91.189.91.13 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/hardy-security/Release.gpg  Could not connect to security.ubuntu.com:80 (91.189.92.166), connection timed out [IP: 91.189.92.166 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/hardy-security/main/i18n/Translation-en_US.bz2  Unable to connect to security.ubuntu.com http: [IP: 91.189.92.166 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/hardy-security/restricted/i18n/Translation-en_US.bz2  Unable to connect to security.ubuntu.com http: [IP: 91.189.92.166 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/hardy-updates/Release.gpg  Unable to connect to archive.ubuntu.com http: [IP: 91.189.91.13 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/hardy-updates/main/i18n/Translation-en_US.bz2  Unable to connect to archive.ubuntu.com http: [IP: 91.189.91.13 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/hardy-updates/restricted/i18n/Translation-en_US.bz2  Unable to connect to archive.ubuntu.com http: [IP: 91.189.91.13 80]

W: Some index files failed to download, they have been ignored, or old ones used instead.
W: You may want to run apt-get update to correct these problems
root@ubuntu:~#

and my source.list file is :

deb cdrom:[Ubuntu 8.04.4 _Hardy Heron_ - Release i386 (20100121.1)]/ hardy main restricted
deb http://archive.ubuntu.com/ubuntu hardy main restricted
deb-src http://archive.ubuntu.com/ubuntu hardy main restricted

deb http://security.ubuntu.com/ubuntu hardy-security main restricted
deb-src http://security.ubuntu.com/ubuntu hardy-security main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://archive.ubuntu.com/ubuntu hardy-updates main restricted
deb-src http://archive.ubuntu.com/ubuntu hardy-updates main restricted

## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
# deb http://archive.ubuntu.com/ubuntu hardy universe
# deb-src http://archive.ubuntu.com/ubuntu hardy universe
# deb http://archive.ubuntu.com/ubuntu hardy-updates universe
# deb-src http://archive.ubuntu.com/ubuntu hardy-updates universe
# deb http://archive.ubuntu.com/ubuntu hardy-security universe
# deb-src http://archive.ubuntu.com/ubuntu hardy-security universe

I couldn't solve this problem.

share|improve this question

marked as duplicate by Anwar Shah, RolandiXor, ajmitch, Mitch, htorque Aug 21 '12 at 17:47

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

1 Answer 1

I'm afraid that Ubuntu 8.04 has reached its end of support date; updates will no longer be available for this version. You should consider upgrading to the latest LTS release, Ubuntu 12.04.

You can check the End of Life chart here for exact dates that specific releases reach (or have reached) the end of their support cycle.

Also check this question for a help on getting updates of end-of-lifed Ubuntu versions:

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.