Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use Ubuntu 12.04. My graphics card is Geforce GT540M.

I opened Synaptic Package manager and installed the following:

  • nvidia-common
  • nvidia-settings-update
  • nvidia-common
  • nvidia-current
  • nvidia-current-updates

The following were installed before(when unity launcher looked normal):

  • jockey-common
  • psensor
  • nvidia-settings
  • jockey-gtk
  • xserver-xorg-video-nouveau

My intention was to use the right Nvidia drivers. But apparently it didn't rightly install the drivers and now I have Unity 2D running!

share|improve this question
post some info about your graphics card. type sudo lshw in the terminal and post the appropriate part. – Ashu Jul 15 '12 at 15:36
I'm sorry, what exactly should I post? Just GPU related? – learner Jul 15 '12 at 17:27
up vote 1 down vote accepted

Execute on a terminal (Ctrl+Alt+T) dpkg -l | grep nvidia- to list all NVIDIA related packages.
Remove them all except nvidia-common, e.g. sudo apt-get purge nvidia-current nvidia-current-updates nvidia-settings-updates.
Install only nvidia-current: sudo apt-get install nvidia-current.

Install via the software center

Reboot your computer.

share|improve this answer
Thanks, but this wouldn't work for me, since my card is an Optimus card and there are no proprietary drivers for it on linux. – learner Sep 23 '12 at 13:23

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.