Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My wireless works fine, but from time to time, annoyingly enough, usually upon startup, it asks for the password, while at the same time displaying it underneath. So, I just have to click 'apply' etc., but at this point it tries to connect, and 80% of times fails and comes back to the same message asking for the very password that's there under my eyes. So, what is seemingly NOT doing at this point is proceeding with an automatic connection, which it is set to do and usually does, when this quirk doesn't arises.

After many attempts it would end up connecting but I am not waiting for that anymore for I have my solution: removing my connection from the 'Edit connections / Wireless' list and putting the wireless back in manually. But I would like not to have to do it manually and avoid this altogether.

I am in 12.04, and my network hardware report in lshw is:

 description: Wireless interface
   product: PRO/Wireless 2200BG [Calexico2] Network Connection
   vendor: Intel Corporation
   physical id: 4
   bus info: pci@0000:02:04.0
   logical name: eth1
   version: 05
   serial: 00:15:00:3b:d1:20
   width: 32 bits
   clock: 33MHz
   capabilities: pm bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=ipw2200 driverversion=1.2.2kmprq firmware=ABG:9.0.5.27 (Dec 12 2007) ip=192.168.0.12 latency=64 link=yes maxlatency=24 mingnt=3 multicast=yes wireless=IEEE 802.11bg
   resources: irq:21 memory:c8400000-c8400fff
share|improve this question
    
Try setting ipv6 tab setting to none/disabled. It's supposed to be a fix for a similar issue with adhoc wifi over Broadcom. –  Capt.Nemo Jul 15 '12 at 15:57
    
If you mean the ipv6 tab of 'Edit Connections/Wireless' and then selecting my connection:'Edit' - which allows the option 'Ignore'- No, it doesn't change the situation for me. And I dont use ad hoc. And it says Intel wireless. –  cipricus Jul 15 '12 at 20:01
    
sometimes the trick with removing connection from list doesn't work and I try other tweaks like disabling wireless. at that point it would not start again but say it was shut by hardware. to which I react by the magic formula 'sudo rfkill unblock wifi' –  cipricus Jul 27 '12 at 19:05
    
this problem never re-appeared in 12.10, with LXDE or Xfce –  cipricus Jun 7 '13 at 11:27
add comment

1 Answer

I have an HP dv4-2070us laptop with an Intel PRO Wireless chipset as well, and encountered this problem in Ubuntu 11.10 and 12.04. The problem for me seems to have been the Channel Width on my wireless router. during the time I was having this issue, both routers I owned were set to "Auto (20MHz or 40MHz)."

Logging in to my router and changing Channel Width to "20 MHz Only" made the problem go away.

share|improve this answer
    
I use a different system - not a normal router but a tv+phone+internet by wire & wireless all-in-one system (freebox of France), a device that acts like router too but that would not let me touch all the settings. tough luck. thnx anyway –  cipricus Jul 15 '12 at 19:38
    
Sorry to hear that Freebox won't let you change the configuration at all. Is it possible to contact their support staff and request assistance troubleshooting? Channel Width is a starting point, but there may be other issues that I am unable to fathom, since I am unfamiliar with your particular device. –  OpensourceFool Jul 15 '12 at 21:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.