Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I play specific MKV files there is not all the sound. There is actually only the background sound, like a song on the background, but I hear no talking.

The strangest thing is that it is not for all MKV files but for some. I can however not see a difference between the different files.

share|improve this question
    
Which player are you using , try VLC. –  atenz Jul 15 '12 at 13:35
1  
This is happenning probably because you have stereo speakers but that mkv has more than 2 audio channels and the "talking channel" isn't being down muxed to stereo. Go to System Setting/Sound and try to find any configuration related to output mode and change it to Stereo Speakers. –  Eric Carvalho Jul 15 '12 at 13:41
    
Cool thanks that helped! thanks for the tip! –  Marinka Jul 15 '12 at 15:33
    
@Eric Carvalho cool, it helped me too. You should give your answer for upvote. –  bioShark Dec 23 '12 at 0:23
    
@bioShark answer posted. –  Eric Carvalho Dec 23 '12 at 3:56

1 Answer 1

This is happenning because you have stereo speakers but that MKV has more than 2 audio channels and the "talking channel" isn't being down muxed to stereo. Go to System Setting/Sound and try to find any configuration related to output mode and change it to Stereo Speakers.

share|improve this answer
    
Great tip. For me it happened when I plugged my head-phones into my 5.1 sound system. I notice the issue only when I was watching a mkv movie. It's logical when you think about it. –  bioShark Dec 23 '12 at 4:14
    
Solid answer. This only happened to me when watching an MKV movie that only had 5.1 and no other audio tracks –  omouse Jun 16 at 4:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.