Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install phpmyadmin from synaptic.
after successfull installation I noticed the config file is empty so I removed it and tried to install it again but I got this error:

 no type given for question at /usr/share/perl5/Debconf/Question.pm line 22, <GEN1> line 2.
 dpkg: error processing phpmyadmin (--configure):
  subprocess installed post-installation script returned error exit status 29
 Errors were encountered while processing:
  phpmyadmin

now I can't install anything! it continues giving the error to me.

What's the problem?

share|improve this question
1  
Please post the result of dpkg -l | grep -v ^ii | tail -n+6 so we can see what packages are broken. –  Eric Carvalho Jul 15 '12 at 13:23

1 Answer 1

When you use dpkg it leaves uncompleted jobs:

  • See the processes by ps -e.
  • Kill those using the installer with kill <PID>, then try to install again.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.