Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My laptop works perfectly fast with Windows 7 but is very slow in Ubuntu 12.04.When I try to open the dash it takes 1-2 sec.even the normal right click on the desktop for the dropdown options is taking time.I installed preload but it made a very slight change. Everything is up to date.

My laptop is : Lenovo ideapad Z560
500 GB hard drive (dual booting win7 and Ubuntu 12.04)
3 GB RAM
Intel® Core™ i3 CPU M 370 @ 2.40GHz × 4 processor
Nvidia GeForce 310M/PCIe/SSE2
Ubuntu 32 bit

any help?

share|improve this question

closed as too localized by Jorge Castro, RolandiXor, Takkat, Ringtail, Anwar Shah Oct 23 '12 at 7:18

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Have you installed your Graphic Driver. –  atenz Jul 15 '12 at 12:30
    
Graphic driver installed and up to date –  Bharat Jul 15 '12 at 12:31
    
include the Laptop model and Name in your question would be helpful. –  atenz Jul 15 '12 at 12:37
    
post the output: dmesg | tail & sudo hdparm -tT /dev/sda and also the system log file –  shantanu Jul 15 '12 at 12:40
1  
Unity dash is quite slow by default, and that's probably the main factor making your feel that the entire OS is slow. Even though there are some ways to speed up dash, it will still be slow even on high-end hardware. –  Dan Dascalescu Dec 30 '12 at 12:44

2 Answers 2

[   26.993526] NVRM: Your system is not currently configured to drive a VGA console
[   26.993530] NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
[   26.993532] NVRM: requires the use of a text-mode VGA console. Use of other console
[   26.993534] NVRM: drivers including, but not limited to, vesafb, may result in
[   26.993536] NVRM: corruption and stability problems, and is not supported.

Did you see that? System does not have proper nvidia driver. It's running in VGA mode. That's why system is not responsive. Open jockey-gtk (default installed), it will automatically show perfect driver for your graphics card. Install it from there. And also remove your existing driver first.

share|improve this answer
    
This may not be the case. I have the same message on dmesg and I've got the nvidia drivers installed through jockey. It simply doesn't seem to have disabled vesafb. The nvidia kernel module is loaded however and Unity works okay as far as I can tell. Probably not a bad idea to disable vesafb anyway if that message is to be believed –  aphax Nov 8 '12 at 18:06

During installation, how much swap partition did you create? Use ubuntu-tweak janitor to clean and cool your Ubuntu and update Ubuntu using update-manager.

share|improve this answer
    
Let's not go as far as swap partitions... the dash is slow because of ridiculously lame animations. We have far cooler blur & stuff demos 10 years ago in 1k demos, but nowadays we need hardware acceleration to perform a blur. Anyway, this question has been answered several times –  Dan Dascalescu Dec 30 '12 at 12:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.