Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have video tearing with compositing enabled in KWin.

I have 2 monitors in twinview, VBlank is set to sync with one of them. I have some tearing on that monitor anyway, and it's much worse on the other one.

The horizontal tearing occurs everywhere on the desktop, I can see it when dragging windows and such.

I'm on 12.04 with the proprietary 302.17 drivers. VSync is enabled everywhere (in KWin and nvidia-settings). I have nvidia-settings --load-config-only in startup.

The only way I can get rid of the tearing is to disable compositing, and I don't want to do that. Compiz can run with no tearing, so should KWin.

I have tried everything, I don't know what to do anymore. I've been googling for weeks. I am at my wit's end.

share|improve this question
add comment

2 Answers 2

I have the same problem. Nvidia 660ti KDE 4.8 and 304 drivers.

I ran some tests with different configurations (Nvidia settings and KWin) and it is related to the PowerMizer settings. On adaptive, I get tearing both on desktop and video (both with VDPAU and without). On max performance, tearing is gone.

Hope it helps.

share|improve this answer
add comment

There is a very good tutorial on how to fix video tearing in Ubuntu on OMG! Ubuntu.

I hope this link can solve your question.

share|improve this answer
    
I cannot utilize Compiz Config under KDE. –  Nick Jul 15 '12 at 10:15
    
Maybe this could help? –  slashcrack Jul 15 '12 at 10:34
    
I'm using KDE, not Compiz. Compiz is not running on my system. –  Nick Jul 15 '12 at 10:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.