Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Gimp 2.6.12 on Ubuntu 12.04. It worked fine until a couple of days ago. This might or might not be relevant, but in the meantime, I tried to plug in my usb photo scanner but since it was not recognized by SimpleScan I didn't continue to bother (will do later).

So now I start Gimp and load an image (image type doesn't matter). The image is loaded fine but as soon as I attempt to use any tool by clicking onto the image, the entire screen goes black and for a very short time, some error message appears in the upper left corner (to short to read). After that, I'm presented the logon screen (all applications are killed).

I've tried to uninstall Gimp, restart and reinstall, but that didn't help. Do you have any advice? Please note that I'm a newby (windows deserter) to Ubuntu.

share|improve this question

closed as off topic by Eliah Kagan, Thomas W., Mitch, Bruno Pereira Jul 16 '12 at 20:22

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Try to open the error console before using any tool. You can access the error console by navigating to Menu -> Windows -> Dockable Dialogs -> Error Console; now use a tool and look if any text appears in the console. If there is any text, we know that something in Gimp itself causes the problem. –  slashcrack Jul 15 '12 at 9:46
    
Alright, I figured out what the problem is: It's the mouse (Nexus Wireless Silent Mouse). Removing its receiver from the USB port and using the Touchpad of my laptop instead solves the problem. Weird, that it only occured in Gimp. Don't know if this question should be closed now. Any advice? –  Matthias Jul 15 '12 at 18:13
    
I observe the same with my Thinkpad T410s since recently. Did anybody find or create a bug report for this? Some more infos: It crashes or crashes not, depending of me pressing Fn+F8 before that. Fn-F8 changes between Touchpad enabled/disabled. I however always use the touch point.. So the bug is somewhere in X11/input devices. –  alfonx Jul 16 '12 at 4:41
    
Enabling the touchpad solves the issue for me as well (Asus Zenbook). –  Lars Nyström Aug 21 '13 at 15:45
add comment

2 Answers 2

A bug has been filed for your problem: https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1021517

(I guess you can close this question by saying that this is the correct answer.)

share|improve this answer
add comment

Hi I run a Dell Vostro 3450, dual screens and a Logitech wireless mouse. I have been running Precise since I got the machine (about 4 months ago) and have had no problems until this morning (16.07).

The Gimp causes the machine to crash as soon as I try to do anything with an image opened for editing.

Starting the Gimp with the wireless receiver disconnected (and then reconnecting it after opening the image) seems to solve the problem. A nuisance, but at least it seems to work for me. - Jac.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.