Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 12.04 and Skype.

My mic is not working. I have 1 mic attached to the system and another one in my headphone (Beats by Dr. Dre).

I followed these steps:

Turn PulseAudio autospawn off, normally: $ echo "autospawn = no" > ~/.pulse/client.conf

killall pulseaudio

But this did not help me and it disabled my sound after my system restarted. I then tried

echo "autospawn = yes" > ~/.pulse/client.conf

then

pulseaudio -D

It fixed my system sound but still no sound on Skype microphone.

After that, I tried this command

echo "options snd-hda-intel model=acer" | sudo tee -a /etc/modprobe.d/alsa-base.conf > /dev/null

I've also upgraded alsa sound drivers by running:

sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
sudo apt-get update
sudo apt-get install linux-alsa-driver-modules-$(uname -r)

however on the last command:

sudo apt-get install linux-alsa-driver-modules-$(uname -r)
[sudo] password for gaurav: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package linux-alsa-driver-modules-3.2.0-27-generic-pae
E: Couldn't find any package by regex 'linux-alsa-driver-modules-3.2.0-27-generic-pae'

When I type pulseaudio in terminal it shows me

E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.

After all this, my sound system started behaving abnormally. Internal Speakers and headphone or 5.1 speakers both works at same time but still the microphone is not working. I even hear a noise when I don't play anything. It's freaking me out and my microphone problem is after 12.04 . Can I use my headphone microphone? I am having beats headphones.

Details of my system alsamixer

ScreenShot OF SKYPE

ScreenShot OF ubu8ntu

Even Now My system sound OUTPUT connector option is gone here is the screen shot enter image description here

enter image description here

share|improve this question
    
Never, ever kill PulseAudio. It's a careless thing to do. Have you set up your microphone correctly using the Sound Preferences in System Settings? Does it work there? –  cumulus007 Jul 15 '12 at 6:55
3  
Please reboot your computer, start Skype normally and add a screen shot of the Skype sound settings and a screenshot of the sound input option under the Ubuntu sound settings. –  Bruno Pereira Jul 15 '12 at 7:13
    
@BrunoPereira I Posted Screenshot of both , but i am facing one more problem i notic now that my 5.1 speaker and my internal speaker both is working when i plug my 5.1 audio jack . Even when i plug my headfone . Before this is was not like this . –  Gaurav_Java Jul 15 '12 at 15:25
    
@Gaurav_Java you should add that to the post with more information about it. –  Bruno Pereira Jul 15 '12 at 16:04
    
@BrunoPereira I posted with MY alsamixer information –  Gaurav_Java Jul 16 '12 at 3:28

14 Answers 14

up vote 13 down vote accepted

Changing Device Input values under gstreamer-properties fixed it for me.

Source

enter image description here

share|improve this answer
    
Thanks! I was having issues and this sorted it –  Matt H Nov 16 '12 at 5:24
1  
Glad it worked for you. –  Srinivas Gowda Nov 17 '12 at 18:26
    
Same issue here but with ubuntu 12.10 and skype 4.0.0.8. The fix not working :( –  Max Małecki Dec 1 '12 at 15:17
    
Thanks dude, after lot of searching I found this answer and it worked immediately. –  Shashwat Kumar Oct 5 at 13:40

My solution

I think that the problem lies within a non-intuitive way of adjusting the recording settings.

Within skype, do the following:

  • Open options dialog.
  • Go to Sound Devices.
  • Click on 'Open PulseAudio Volume Control'.

Here comes the non-intuitive part!!!

Under the 'Recording' tab...

If no program is recording anything (being in idle mode) it shows nothing at all. One might think that there is nothing to this tab of interest, but one would be mistaken!!! Keep this tab open and visible. Make sure the 'Show' option at the bottom is set to either 'All Streams' or 'Applications'.

Start a test call from the options dialog.

The pulseaudio dialog will now show what program is recording sound from where.

Skype: Input from...

To the right of this text, select your input device and it should finally work.

It took me a while to figure this one out.

Sincere,

Lars Hansson

share|improve this answer

I have head a similar problem on a realtek HD audio system (eeePC R101). After upgrading from Ubuntu (Xubuntu) 10.04 to 12.04, the microphone turned out to be unusable, the sound it recorded was at such a low volume that it could not be used. Using skype was not possible. After looking through a couple of forum entries I summarized people had found pulseaudio not working on this type of sound card. In contrast to older skype versions that required pulseaudio, the current skype (4.1) also uses ALSA. This, however, requires pulseaudio to be uninstalled. If you don't really need pulseaudio for other reasons, give this a try:

sudo apt-get remove pulseaudio

Then reboot the system and try using skype. Make sure to turn off "allow skype to adjust mixer levels" in the audio settings and make sure in Alsamiser or XFCE4-mixer that the microphone is turned on.

Hopefully someone finds out why pulseaudio capture does not work on Realtek HD anymore.

share|improve this answer
1  
thanks. for me usb microphones and even normal ones did not work but this helped for the normal mics and for usb! –  Karussell Jan 11 '13 at 16:59
    
This also resolved my problem with USB webcam microphones on several machines, once the other microphone inputs are muted. You do need an older version of Skype though, because alsa is no longer supported since version 4.3. Look here for it. –  Gin Gordon Jun 21 at 8:40

I had similar problem. My problem was not that the microphone was not working, but rather the microphone volume was much too low and they could hardly hear me on the other side. I fixed it by installing PulseAudio Volume Control (available from Ubuntu Software Center). Run the application, go to Input Devices and try increasing the volume of your microphone with the slider (it goes up to 153% in my case). It helped me fix my problem. Keep in mind that at some point the volume is again reset to 100% and you have to start the PulseAudio Volume Control application again and repeat the volume increase.

Btw, if you hear noise when not speaking, it is very likely that the system is using your built-in microphone. Go to System Settings -> Sound -> Input tab and select the appropriate Input device from there.

share|improve this answer
    
this i done before nothing works .... i tired again but nothing happen –  Gaurav_Java Jul 17 '12 at 10:56
    
Can you be more specific? Were you able to increase the mic volume past the 100% mark? How are you testing it - have you tried Skype Echo service? When you say "nothing happen", does this mean that you hear noise, or nothing, or something else? –  Stefan Buynov Jul 17 '12 at 11:28
    
I am not able to hear my voice in skype if i make it full as you said 153% then i am only able to hear some sort of noise and one thing wearied happen . that when ever i play and sound it is coming with noise –  Gaurav_Java Jul 17 '12 at 12:39
    
Can you confirm that when you go to System Settings -> Sound -> Input the appropriate microphone is selected? By looking at your screenshots, I would assume you have to choose Microphone or Front Microphone. –  Stefan Buynov Jul 17 '12 at 13:05
    
Yes i can confirm that i ahve selected microphone option . even bar in microphone is increasing and decreasing. but no sound –  Gaurav_Java Jul 17 '12 at 14:57

I had a no sound on my Microphone problem, also. I feel real silly about this one. I hadn't used the Microphone for a LONG time. When it came time for me to need it, it wouldn't work.

I spent hours looking for solutions online. Turns out though that it was just a physical connection issue. I use a headset that has a little arm thingy that hangs down by my mouth. The arm contains the Microphone. Well, silly me... the arm wasn't pushed all the way into the headset.

One thing I will suggest for people is that they try to verify functionality in Windows if they don't have luck in Linux. Perhaps you'll find that your Microphone has a problem, if it also doesn't work in Windows.

Cheers!

share|improve this answer
    
+1 for bravely pointing out the most obvious - things like these happen all the time. –  aquaherd Feb 9 '13 at 23:44

I did everything mentioned here. Also, Installed skype from software centre, installed ia32-libs

but nothing worked. But what worked is:>>

open gstreamer-properties, and set in Audio tab> Default Input > Plugin = PulseAudio Sound Server

I cudnt add the image as I don't have enough 'reputation' here on this forum. LOL!!!

And now , mic is working , in USB Headphone. In default mic , its not working with this setting but thats ok for the moment. Leaving that part for later on or someone here on the forum!!

I guessed this fix when I saw everyone was commenting that Skype is using PulseAudio. I am happy now !!

share|improve this answer

Quickly sharing my experience there :

Once on Ubuntu 12.04, sound input (onboard mic-in) drove me mad for some time.

TL;DR first: I could avoid the microphone problem switching desktop environment to gnome-shell (or gnome-session-fallback). It sounds weird but it's obvious on my rig.

I've read a lot, tried a lot, without success.

On Unity desktop, the (default) sound control panel will show a wrong audio device :

"Stereo analog output + Digital Stereo (IEC958) input" (my hardware isn't even capable of digital stereo input)

While the right one should be "Analog Stereo duplex" .

Any tweak through "pavucontrol" wouldn't have any effect.

Later, I've tried the latest gnome desktop (gnome-shell). While on gnome-shell, "Analog Stereo duplex" was available to pick and all was working as it should. Back on Unity, the problem was back again.

I have no clue how this can possibly be related to Unity, but somehow it is.

share|improve this answer

I got the same problem on a 12.10 64-bit, and I saw skype crashing while searching for some pulse audio lib under a 32-bit path.

By installing ia32-libs Install ia32-libs I solved the problem.

share|improve this answer

I had audio and video problem for at list a month! Visited several forums and tried many different troubleshooting. At last uninstall Skype and re-install from Ubuntu software Center it works perfectly now. (At first I downloaded from Skype website).

share|improve this answer

My answer might come a bit late but maybe it'll help somebody one day. It seemed that all of sudden my microphone stopped working in skype although it still worked with all other programs. I tried all the solutions mentioned in this post (and more) but none of them worked...

What worked for me was deleting the pulseaudio config and profile files so that pulseaudio is forced to generate new ones:

rm -r ~/.pulse/

restart pulseaudio or your computer afterwards

(ubuntu 12.04 64bit, skype 4.2.0.11, pulseaudio 1.1, 5.1 usb sound card)

share|improve this answer

I found a solution about volume , opened one terminal and will type:

alsamixer

and turn up the value in the mic boost column, with this changes, my skype capture sounds really good.

share|improve this answer

After having this problem linger for quite a few weeks using Ubuntu 12.04 and trying literally dozens of suggestions, I can confirm pulseaudio as the culprit. The suggestion by jhench in my case at least, finally solved the problem:

sudo apt-get remove pulseaudio

After running the above on a terminal and restarting my system, Skype and all other applications that used the built in microphone on my Asus Zenbook began to work reliably.

There are far too many suggestions out posted throughout various sites which simply do not work, and many do more harm than good. One even suggested installing pulseaudio. I hope my confirming that this particular solution helps others in a similar set of circumstances.

share|improve this answer

I would also recommend to uncheck "Allow Skype to automatically adjust my mixer levels" in the "Sound devices" Skype settings.

In my case Skype was muting my microphone all the time automatically.

share|improve this answer

Скачай и установи gnome alsa mixer и тогда микрофон заработает нормально

Translation:

Download and install gnome alsa mixer and then the microphone will function normally

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.