Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have only had ubuntu for about a month, when i got it i had no problem connecting to our netgear router using an ethernet cable. We have just replaced our router with an identical one (due to lightning blowing our last one up). I was unable to set up the new router on my computer as the disc wouldnt load, so we set it up on my brother win 7 machine. it seems to work fine and i can connect to it wirelessly on my dads ubuntu 10.04 machine. my computer just doesnt connect, when i go onto network connections in settings it just says cable unplugged, which it isnt. There is no light on for the port my computer is plugged into on the router, although this makes sense as usually the computer has to tell the router it has set up. i have tried manually setting it up through the network manager using the addresses i got from this machine connected wirelessly, i have tried many restarts under different settings. is there anything i can do to make ubuntu see my connection? Thankyou

share|improve this question
    
Can you check that your dad's/brother's/etc. computer can connect to the router with a cable and that the light for that port on the router comes on? –  izx Jul 15 '12 at 0:38
add comment

2 Answers 2

I'd suspect the following statement

There is no light on for the port my computer is plugged into on the router, although this makes sense as usually the computer has to tell the router it has set up.

The port light on your router is typically lit due to, not software or TCP/IP settings, but electrical connectivity. If you plug into the router, and the router's light doesn't go on for that port, you may have a bad port at the router, bad cable, or bad ethernet port on the computer. Possible that you were connected to that router during the lightning strike and took some electrical damage ? I'd get systematic and get my hands on a different cable, try different ports on the router, and also try the same cable and same port with a different computer. Please let me know how your troubleshooting proceeds.

share|improve this answer
    
ah, thanks, hadn't thought of that, will give it a go tomorrow and update –  Lewes Jul 15 '12 at 0:22
add comment

When there's a lightning strike, anything physically connected to a device that was directly affected is likely to have damage done to it as well.

One of the indicators of a bad ethernet port is if it switches from 100M/Full Duplex to 10M Full or half. I've found that anything displaying these characteristics should soon be, if not already, dead.

As Oyrm mentioned, I would definitely go through every possible configuration you can think of with swapping wires and equipment. Make sure you have a definite cause pinned down if at all possible, that way you can pick the most effective course of action and not spend a small fortune monkey patching something.

share|improve this answer
    
ok, i plugged the cable into the laptop nad it connected fine, i also checked the other computer (XP) which was connected by cable at the time and that also worked fine, so if there was a current going down the cables, it didnt go down that one. I think this is unlikely as i opened up the router and the chip had blown up, the was a small hole in it and a scorch mark on the other side. I am moving in a few weeks and will be getting a new router, so if it doesnt work with that either it will require further investigation. –  Lewes Jul 15 '12 at 22:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.