Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Typing ls /sys/class/backlight/*/brightness outputs

/sys/class/backlight/intel_backlight/brightness
/sys/class/backlight/samsung/brightness

The max_brightness for the second is 8, but changing it with echo 2 | sudo tee /sys/class/backlight/samsung/brightness doesn't change brightness. I can do it by using intel_backlight: echo 2000 | sudo tee /sys/class/backlight/intel_backlight/brightness (max_brightness: cat /sys/class/backlight/intel_backlight/max_brightness outputs 4648).

But I want to do this work with the fn brightness keys, as I always did. I don't know what happened to stop working, maybe the use of +1 monitor and removing it in a wrong time or a system update.

I'm using Ubuntu 12.04 64 bits in an Samsung RV420 notebook. Kernel Version is 3.2.0-27-generic.

Could you help me? Please tell me what more info should I provide.

Thanks!

share|improve this question
    
Have you checked the "related" questions on brightness that appear in the sidebar? Not sure they will help, but generally you'll get good ideas that way. –  belacqua Jul 14 '12 at 23:52
    
yes, can't get a fix :s –  nicholascamp Jul 17 '12 at 1:15
    
Google 'samsung easy display option download' which will restore all fn functions. I'm pleased to say I have just done this to restore the brightness function etc. on my samsung RV520 and all now work. Hope it works for you. Conbrio –  user113239 Dec 7 '12 at 10:59
add comment

2 Answers 2

up vote 4 down vote accepted

A bug seems to have made its way into 3.2.0-27.

The only practical solution I found was to downgrade back to 3.2.0-26.

Assuming you previously had that kernel on this box and recently upgraded, you can boot this kernel temporarily via the grub2 menu: * Reboot, and depress and hold the left-shift key until the boot menu appears. * Select the previous versions menu. * Choose 3.2.0-26 if available, or the latest (but pre- 3.2.0-27, of course.)

In the meantime if you're 'stuck in the dark,' I posted a kludge on the bug report that should let you temporarily restore max brightness.

share|improve this answer
    
Yes, that was the problem! I booted with 3.2.0-26, now I can adjust brightness normally. A new boot version will ship soon, with this bug probally fixed, right? The trick with sudo tee also deal with the problem. Thanks. :) –  nicholascamp Jul 25 '12 at 14:05
    
Good to know that wasn't a bug with the use of another monitor. :) –  nicholascamp Jul 25 '12 at 14:12
add comment

Couldn't change graphics with Fn keys on my Acer laptop.

This helped me (notice a little bit different parameter), added to /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force acpi_backlight=vendor"

Then runupdate-grub and reboot.

Source: http://www.refreshit.info/2012/08/solved-brightness-increase-and-decrease.html

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.