Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to hide bottom panel so that I would be able to show it again when I want. In the properties menu of the panel there is an option for Autohide but not hide totally.

The reason I need it, is because I am using Docky panel and it now it is behind the bottom panel and looks like awful.

What I am doing right now is I am deleting it totally by right clicking on the panel. And the only way I know to return it back is executing following command in the terminal.

rm -r ~/.gconf/apps/panel

Any other solutions?

share|improve this question
1  
If you have removed it, you can add it again by right clicking the top panel, and clicking new panel. You can then add the applets you want to the bottom panel again. Tedious, but at least it does the job. –  RolandiXor Dec 6 '10 at 21:58

5 Answers 5

up vote 9 down vote accepted

You can enable buttons to hide the panel whenever you want - if you don't want to delete the panel altogether:

To do this, right click the panel, select Properties and check Show hide buttons

share|improve this answer
    
He is not looking for the hide button, but how to reduce the size of a auto-hidden panel. –  soc Dec 6 '10 at 10:36
    
Are you sure about that? He writes: "...so that I would be able to show it again when I want". –  Stefano Palazzo Dec 6 '10 at 12:50
    
"...there is an option for Autohide but hide totally not." Imho and afaik this refers to the 6 pixels which remain to be displayed (in older versions of Gnome) even if the panel is auto-hidden. –  soc Dec 6 '10 at 13:57

Here's the best way to hide the gnome panel:

  1. Install compiz and ccsm
  2. Open ccsm and enable the "widget layer" feature
  3. In the widget layer options, go to "behaviour" tab
  4. Add the line name=gnome-panel in the field widget windows
  5. Close ccsm

Once this is done you will see the gnome panels only when you display the widget layer. the default key for this is F9

share|improve this answer
  1. Alt+F2
  2. Type gconf-editor
  3. Browse to apps/panel/toplevels/panel_1/monitor
  4. Set value to -6
  5. Finish
share|improve this answer

I simply recommend to remove the bottom panel. Docky replicates the full functionality of the bottom panel, so you do not need it.

share|improve this answer

Are you maybe using an older Ubuntu version? I wrote a Gnome patch a long time ago, which changed the standard auto hide size to 0/1 pixel. At least the last two Gnome versions should ship with that patch.

Of course you can also change it manually:

  • Open the application gconf-editor. If you don't have it, install it.
  • Go to /apps/panel/toplevels/bottom_panel_screen0
  • Change the value auto_hide_size to 0 or 1.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.