Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

little problem i want to transfer from my windows to ubuntu because its amazing but my wireless usb isnt picked up on ubuntu so its completely offline and i dont know how to download or transfer the driver for it over to ubuntu the computer calls the wireless 802.11n wireless LAN card although on the ralink website that doesnt come up but i think its a RT5370 which i can download on my windows computer but i cant transfer it over to ubuntu via memory stick etc so yeah any help would be appreciated kind of dont want to be forever doomed in windows:D

share|improve this question
    
Please run lsusb and post the output here, so we can determine what kind of WiFi hardware your machine has. –  cumulus007 Jul 14 '12 at 20:52

2 Answers 2

You are using RT5370 USB device. Download the driver from here.

Give you Name & E-mail address and press Accept.

I assume you download it in Downloads folder.

Now open a terminal by pressing Ctrl+alt+t and type...

cd ~/Downloads

unzip Realtek_RTS5229_Linux_Driver_v1.07.zip

it will unzip the arcive in same folder.

cd Realtek*

There is a tar.bz2 type file.. untar it by typing

tar jxvf rts*

cd rts*

Now the installation part.

UPDATE : I forgot to mention, you need some dependent package to install sudo apt-get install build-essential to solve this.

make

make install

sudo -s

depmod

reboot

Done. Hope it helps.

share|improve this answer
    
Not going to work unless he gets build-essential and the kernel headers... –  izx Jul 15 '12 at 2:12
    
Really sorry, I forgot to mention that. I tried this in my machine which have this package installed. Thanks for the correction. –  Kaktarua Jul 15 '12 at 4:38

Have you tried disabling the power management of your wlan0 device? This did the magic for my €15,- brandless wireless-n usb adapter that has the Ralink 5370 chipset in it. I let (X)ubuntu 12.04 load the pre-built rt2800usb kernel module that seems to work very well with this device. No need to download anything.

You can check the status of the adapter's power management;

iwconfig

If it is returning a line that says "Power Management:on", than you can turn it off like this;

sudo iwconfig wlan0 power off

To make this persistant every time you boot, make a small script that contains the line above;

sudo touch /etc/pm/power.d/wireless

Now make the file executable;

sudo chmod 755 /etc/pm/power.d/wireless

Now insert the lines in the "wireless" file;

sudo cat > /etc/pm/power.d/wireless
#!/bin/sh
/sbin/iwconfig wlan0 power off

Press "ENTER" and press "Ctrl+D".

Now reboot the computer and check whether power management of the wlan0 adapter is really off;

iwconfig wlan0

Good luck!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.