Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I get this message while trying to install Ubuntu 12.04 as a guest in VirutalBox 4.1.18, on an Ubuntu 10.04 host.

This kernel requires the following feature not present on the CPU: pae

Some host specs:

  • The host's kernel is: Linux 2.6.32-41-generic-pae GNU/Linux
  • lscpu (host): Architecture: i686, CPU op-mode(s): 32-bit, 64-bit
  • grep --color=always -i PAE /proc/cpuinfo   does show pae in its output.

The 12.04 iso used is: ubuntu-12.04.0-desktop-i386.iso

As a comparison/check, I downloaded and installed Linux Mint 13 Cinnamon to the same host on the exact same VM (I just changed the .iso image). It worked fine. Its iso is: linuxmint-13-cinnamon-dvd-32bit.iso

It seems (to me) that I have pae.. what is going on here?

Update: I had assumed that Linux Mint also required pae (being Ubuntu based), but I've just run;   grep --color=always -i PAE /proc/cpuinfo   in the Mint VM.   It showed no output.   So it seems the issue may lie with VirtualBox.   If that is the case, how can I get Virtualbox into pae mode?

share|improve this question
1  
Ubuntu 12.04 comes with a pae kernel as default. This may be different with Mint. –  Takkat Jul 14 '12 at 18:39
add comment

1 Answer

up vote 13 down vote accepted

On VirtualBox Manager, open your virtual machine configuration then select System on the left side and open the Processor tab. Be sure that Enable PAE/NX is checked.

enter image description here

For commandline

VBoxManage modifyvm <VM_name> --pae on
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.